Hdu 4565 So easy! 2013长沙邀请赛

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 133    Accepted Submission(s): 43


Problem Description
  A sequence S n  is defined as:

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
  You, a top coder, say: So easy!  
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2 15, (a-1) 2< b < a 2, 0 < b, n < 2 31.The input will finish with the end of file.
 

Output
  For each the case, output an integer S n.
 

Sample Input
  
  
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
  
  
4 14 4
 

Source
 

Recommend
zhoujiaqi2010
 

 

#include <stdio.h>
void mmul(int a[2][2],int b[2][2],int c[2][2],int m)
{
int d[2][2],i,j,k;
for(i=0;i<2;++i)
	for(j=0;j<2;++j)
		for(k=d[i][j]=0;k<2;++k)
			d[i][j]=(d[i][j]+((a[i][k]*b[k][j])%m))%m;
for(i=0;i<2;++i)
	for(j=0;j<2;++j)c[i][j]=d[i][j];
}
void mpow(int a[2][2],int b,int c[2][2],int m)
{
	int t[2][2],d[2][2],i,j;
	for(i=0;i<2;++i)
		for(j=0;j<2;++j)
		{
			d[i][j]=a[i][j]%m;
			t[i][j]=i==j?1:0;
		}
	while(b)
	{
	if(b&1)
		mmul(t,d,t,m);
		mmul(d,d,d,m);
		b>>=1;
	}
	for(i=0;i<2;++i)
		for(j=0;j<2;++j)
			c[i][j]=t[i][j];
}

int main()
{
//freopen("easy.in", "r", stdin);
//freopen("testeasy.out", "w", stdout);
int a,b,m,n,c[2][2],r,i,j;
while(scanf("%d%d%d%d",&a,&b,&n,&m)!=EOF)
{
	c[1][0]=1;
	c[1][1]=0;
	c[0][0]=(a<<1)%m;
	c[0][1]=(b-((a*a)%m))%m;
	mpow(c,n-1,c,m);
	r=(((((((c[0][0]*2)%m)*a)%m)+(c[0][1]*2)%m)%m)+m)%m;
	printf("%d\n",r);
}
return 0;
}


 

 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值