[C++] PAT 1076 Forwards on Weibo (30分)

在这里插入图片描述

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题解:

该题是图的BFS,
1.题目中有层数限制,则将访问标志数组vis[],用访问层数标志结点是否被访问,注意每次进行BFS前将其初始化

#include <iostream>
#include <queue>
using namespace std;

const int MAXV = 1010;

int n,G[MAXV][MAXV]={0};//n人数, G邻接矩阵
int l;//l层数
int vis[MAXV];//vis表示该结点是在第几层转发的
int ans = 0;

void BFS(int u){
	queue<int> q;
	q.push(u);
	vis[u] = 0;
	ans = 0;
	while(!q.empty()){
		int a = q.front();
		q.pop();
		for(int i=1;i <= n;i++){
			if(G[a][i] == 1 && vis[a] < l && vis[i] == -1){
				q.push(i);
				vis[i] = vis[a] + 1;
				ans += 1;
			}
		}
	}
	cout << ans << endl;
}

int main(){
	cin >> n >> l;
	int follow_num,temp_follow;
	for(int i=1;i <= n;i++){
		cin >> follow_num;
		for(int j = 0; j< follow_num;j++){
			cin >> temp_follow;
			G[temp_follow][i] = 1;
		}
	}

	int need_solve,temp_solve;
	cin >> need_solve;
	for(int i=0;i < need_solve;i++){
		cin >> temp_solve;
		for(int i=1;i <= n;i++){//初始化vis[]
			vis[i]=-1;
		}
		BFS(temp_solve);
	}

	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值