poj3468(线段树)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 58221 Accepted: 17741
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... ,AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1,A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... ,Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

线段树模板题,区间更新,区间求和

#include<set>
#include<queue>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<utility>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define Inf (1<<30)
#define LL long long
#define MOD 1000000009
#pragma comment(linker, "/STACK:102400000,102400000")  
using namespace std;
const int MM = 110005;
LL sum[MM << 2];
LL add[MM << 2];
void pushup(int o)
{
	sum[o] = sum[2 * o] + sum[2 * o + 1];
}
void pushdown(int o, int L, int R)
{
	if (add[o])
	{
		int mid = L + (R - L) / 2;
		add[2 * o] += add[o];
		add[2 * o + 1] += add[o];
		sum[2 * o] += add[o] * (mid - L + 1);
		sum[2 * o + 1] += add[o] * (R - mid);
		add[o] = 0;
	}
}
void build(int o, int L, int R)
{
	add[o] = 0;
	if (L == R)scanf("%lld",&sum[o]);
	else
	{
		int mid = L + (R - L) / 2;
		build(2 * o, L, mid);
		build(2 * o + 1, mid + 1, R);
		pushup(o);
	}
}
void update(int o, int L, int R, int x, int y, int z)
{
	if (x <= L&&R <= y)
	{
		sum[o] += z*(R - L + 1);
		add[o] += z;
	}
	else
	{
		int mid = L + (R - L) / 2;
		pushdown(o, L, R);
		if (x <= mid)update(2 * o, L, mid, x, y, z);
		if (mid < y)update(2 * o + 1, mid + 1, R, x, y, z);
		pushup(o);
	}
}
LL query(int o, int L, int R, int x, int y)
{
	if (x <= L&&R <= y)return sum[o];
	else
	{
		int mid = L + (R - L) / 2;
		LL res = 0; 
		pushdown(o, L, R);
		if (x <= mid)res += query(2 * o, L, mid, x, y);
		if (mid < y)res += query(2 * o + 1, mid + 1, R, x, y);
		return res;
	}
}
int main() {
	int n, m, q;
	//freopen("D:\\oo.txt","r",stdin);
	while (~scanf("%d%d", &n, &m))
	{
		build(1, 1, n);
		while (m--)
		{
			char s[10];
			int x, y, z;
			scanf("%s", s);
			if (s[0] == 'C')
			{
				scanf("%d%d%d", &x, &y, &z);
				update(1, 1, n, x, y, z);
			}
			else{
				scanf("%d%d", &x, &y);
				printf("%lld\n", query(1, 1, n, x, y));
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值