POJ3468 线段树

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 69540 Accepted: 21416
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


可以用线段树lazy标记的方法做,有两个要注意的地方。

一个是这道题用cin,cout会超时,只能用printf和scanf。

还有一个是更新的时候,第44和45行,要小心别写错,因为把root写成p而wa了一个晚上。

#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
using namespace std;
#define maxN 100004
struct nodes
{
    int l,r;
    __int64 sum;
    __int64 val;
}node[4*maxN];
int a[maxN];
__int64 sum;
char x[2];
void build(int root, int l, int r)
{
    node[root].l=l;
    node[root].r=r;
    node[root].sum=node[root].val=0;
    if(l==r)
    {
        node[root].sum=a[l];
        return;
    }
    int mid=(l+r)/2, p=root*2;
    build(p, l, mid);
    build(p+1, mid+1, r);
    node[root].sum=node[p].sum+node[p+1].sum;
}
void add(int root, int lt, int rt, int value)
{
    int p=root*2;
    if(node[root].l==lt && node[root].r==rt)
    {
        node[root].val+=value;
        node[root].sum+=value*(rt-lt+1);
        return;
    }
    if(node[root].val!=0)
    {
        node[p].val+=node[root].val;
        node[p+1].val+=node[root].val;
        node[p].sum+=node[root].val*1ll*(node[p].r-node[p].l+1);
        node[p+1].sum+=node[root].val*1ll*(node[p+1].r-node[p+1].l+1);
        node[root].val=0;
    }
    int mid=node[p].r;
    if(rt<=mid) add(p,lt,rt,value);
    else if(lt>mid) add(p+1, lt, rt, value);
    else{
        add(p,lt, mid, value);
        add(p+1, mid+1, rt, value);
    }
    node[root].sum=node[p].sum+node[p+1].sum;
}
void query(int root, int lt, int rt)
{
    int p=root*2;
    if(node[root].l==lt && node[root].r==rt)
    {
        sum+=node[root].sum;
        return;
    }
    if(node[root].val!=0)
    {
        node[p].val+=node[root].val;
        node[p+1].val+=node[root].val;
        node[p].sum+=node[root].val*1ll*(node[p].r-node[p].l+1);
        node[p+1].sum+=node[root].val*1ll*(node[p+1].r-node[p+1].l+1);
        node[root].val=0;
    }
    int mid=node[p].r;
    if(rt<=mid) query(p, lt, rt);
    else if(lt>mid) query(p+1, lt, rt);
    else{
        query(p, lt, mid);
        query(p+1, mid+1, rt);
    }
}

int main()
{
    int lt, rt, value, N, Q;
    //freopen("in.txt", "r", stdin);
    scanf("%d%d", &N, &Q);
    for(int i=1; i<=N; i++)
    {
        scanf("%d", &a[i]);
    }
    build(1, 1, N);

    for(int i=0; i<Q; i++)
    {
        //cin >> x;
        scanf("%s", x);
        if(x[0]=='Q'){
            //cin >> lt >> rt;
            scanf("%d%d", &lt, &rt);
            if(lt>rt) swap(lt,rt);
            sum=0;
            query(1, lt, rt);
            printf("%I64d\n", sum);
        }
        else if(x[0]=='C'){
            //cin >> lt >> rt >> value;
            scanf("%d%d%d", &lt, &rt, &value);
            if(lt>rt) swap(lt,rt);
            add(1, lt, rt, value);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值