UVA10305

Problem F

Ordering Tasks

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

 

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers,1 <= n <= 100 andm. n is the number of tasks (numbered from1 ton) and m is the number of direct precedence relations between tasks. After this, there will bem lines with two integersi and j, representing the fact that taski must be executed before taskj. An instance withn = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3



(The Joint Effort Contest, Problem setter: Rodrigo Malta Schmidt)




#include<stdio.h>
#include<string.h>
#define  MM  200
int N,M,a[MM][MM],vis[MM],b[MM];
void delete(int u)
{
    int j;
    for(j=1;j<=N;j++)
        a[u][j]=0;
}
void tuopu()
{
    int sign,i,j,k,o=1;
    for(i=1;i<=N;i++)
    {
        for(j=1;j<=N;j++)
        {
            if(vis[j])  continue;
            sign=1;
            for(k=1;k<=N&&sign;k++)
            {
                if(a[k][j])
                {sign=0;break;}
            }
            if(sign)
            {
                if(o==1) {printf("%d",j);o++;}
                else printf(" %d",j);
                vis[j]=1;
                b[j]=j;
            }
        }
        for(j=1;j<=N;j++)
            if(b[j]!=0)
                delete(b[j]);
    }
}
main()
{
    int i,u,v;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        if(N+M==0)   break;
        memset(vis,0,sizeof(vis));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(i=1;i<=M;i++)
        {
            scanf("%d%d",&u,&v);
            a[u][v]=1;
        }
        tuopu();
        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值