uva133


 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4tex2html_wrap_inline34 8,tex2html_wrap_inline34 9tex2html_wrap_inline34 5,tex2html_wrap_inline34 3tex2html_wrap_inline34 1,tex2html_wrap_inline34 2tex2html_wrap_inline34 6,tex2html_wrap_inline50 10,tex2html_wrap_inline34 7

where tex2html_wrap_inline50represents a space.




#include<stdio.h>
#include<string.h>
#include<ctype.h>
#include<stdlib.h>
#include<math.h>
main()
{
	int i,a[30],vis[30],N,m,k,f,r,count;
	while(scanf("%d%d%d",&N,&k,&m)&&N+k+m)
	{
		memset(vis,0,sizeof(vis));
		count=0;f=N-1;r=0;
		for(i=0;i<N;i++)
			a[i]=i+1;
		while(1)
		{
			i=k;//数k个人
			while(i)
			{
				f++;
				if(f>=N)  f=0;
				if(vis[f]) {continue;}//此下标对应的人已经被数过,跳过下标
				i--;
			}
			i=m;//数m个人
			while(i)
			{
				r--;
				if(r<0) r=N-1;
				if(vis[r])  {continue;}//此下标对应的人已经被数过,跳过下标
				i--;
			}
			if(f==r)//数到同一个人
			{
				if(count==N-1) printf("  %d",a[f]);
				else printf("%3d,",a[f]);
				vis[f]=1;
				count++;
			}
			else
			{
				if(count==N-2)
					printf("%3d%3d",a[f],a[r]);
				else printf("%3d%3d,",a[f],a[r]);
				vis[f]=vis[r]=1;
				count+=2;
			}
			if(count==N)  break;//没有剩下
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值