The Dole Queue
The Dole Queue |
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.
Input
Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).
Output
For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).
Sample input
10 4 3 0 0 0
Sample output
4 8, 9 5, 3 1, 2 6, 10, 7
where represents a space.
约瑟夫问题变形,没用链表实现因为N<20,用数组偷懒下
#include <stdio.h>
void main()
{int N,k,m,i,left,right,step,a[20],num,f1,f2;
while (scanf("%d%d%d",&N,&k,&m),N+k+m)
{for (i=1;i<=N;i++) a[i]=1;
left=0; right=N+1; num=N;
while (num)
{step=0; f1=0;
while (step<k) {++left; step+=a[left]; if (left==N) left=0;}
step=0; f2=0;
while (step<m) {--right; step+=a[right]; if (right==1) right=N+1;}
if (left==0) {f1=1; left=N; }
if (right==N+1) {f2=1; right=1; }
a[left]=0; a[right]=0;
if (left==right) {--num; printf("%3d",left);}
else {num=num-2; printf("%3d%3d",left,right);}
if (num) printf(",");
if (f1) left=0;
if (f2) right=N+1;
}
printf("\n");
}
}