POJ2138-TOYS

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10077 Accepted: 4827

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.
//AC代码
/*
这题题意:就是给你一个长方形箱子(左上角坐标(x1,y1),右下角坐标(x2,y2))里面插入n个插板,把这个长方形箱子
分成n+1区域,然后里面有m个玩具,问你每个区域有多少个玩具(不考虑玩具落在边界和区域外)
这题用叉积就能过了,时间大概是800ms
叉积的一个非常重要性质是可以通过它的符号判断两矢量相互之间的顺逆时针关系:

若 P × Q > 0 , 则P在Q的顺时针方向。(右手定则,叉积大于零代表大拇指向上,即Z的值是正值,四指由P到Q)

若 P × Q < 0 , 则P在Q的逆时针方向。(右手定则,叉积小于零代表大拇指向下,四指由P到Q)

若 P × Q = 0 , 则P与Q共线,但可能同向也可能反向
//计算cross product(P1-P0)x(P2-P0)//几何叉积公式
double xmult(pointp1,pointp2,pointp0)
{
	return(p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}
double xmult(double x1,double y1,double x2,double y2,double x0,double y0)
{
	return(x1-x0)*(y2-y0)-(x2-x0)*(y1-y0);
}
*/


#include<iostream>
#include<cmath>
#include<algorithm>
#include<queue>
#include<cstring>
const int Max=5001;
const int inf=999999;
const double eps = 1e-8;
#define zero(x)(((x)>0?(x):-(x))<eps)
using namespace std;
typedef struct Node
{
    double x;
    double y;
}point;
point node_l[Max];
point node_r[Max];
double k[Max];
double b[Max];
int sum[Max];
double distance(point p1,point p2)
{
    return sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y));
}
double slope(point p1,point p2)
{
    if(p1.x==p2.x)
    return inf;
    else
    return ((p1.y-p2.y)/(p1.x-p2.x));
}
double constant(point p1,point p2)
{
    double k=slope(p1,p2);
    return (p1.y-p1.x*k);
}
double xmult(double x1,double y1,double x2,double y2,double x0,double y0)//求叉积
{
    //cout<<x1<<" "<<y1<<" "<<x2<<" "<<y2<<" "<<x0<<" "<<y0<<endl;
	return(x1-x0)*(y2-y0)-(x2-x0)*(y1-y0);
}
int main()
{
    int n,m;
    double x1,y1,x2,y2,x,y;
    //int p;
    while(cin>>n&&n)
    {
        cin>>m>>x1>>y1>>x2>>y2;
        memset(sum,0,sizeof(sum));//做到后面才发现sum[]没有初始化,搞得WA几次
        for(int i=0;i<n;i++)
        {
            cin>>node_l[i].x>>node_r[i].x;
            node_l[i].y=y1;
            node_r[i].y=y2;
            k[i]=slope(node_l[i],node_r[i]);
            if(k[i]==inf)
            b[i]=inf;
            else
            b[i]=node_l[i].y-k[i]*node_l[i].x;

            //cout<<"k="<<k[i]<<" b="<<b[i]<<endl;
        }
        //node_l[n].x=x2;
        //node_l[n].y=y1;
        //node_r[n].x=x2;
        //node_r[n].y=y2;
        for(int i=0;i<m;i++)
        {
            cin>>x>>y;
            for(int j=0;j<=n;j++)
            {
                //cout<<xmult(node_l[j].x,node_l[j].y,node_r[j].x,node_r[j].y,x,y)<<" xx"<<endl;
                if(xmult(node_l[j].x,node_l[j].y,node_r[j].x,node_r[j].y,x,y)<0)
                {
                    sum[j]+=1;
                    break;
                }

            }
            //if(p==0)
            //{
            //    if(x<x2)
            //        sum[n]+=1;
            //}
        }
        for(int i=0;i<=n;i++)
        {
            cout<<i<<": "<<sum[i]<<endl;
        }
        cout<<endl;
    }
    return 0;
}
/*
            if(k[j]==inf&&b[j]==inf)
            {
                    if(x<node_l[j].x)
                    {
                        p=1;
                        sum[j]+=1;
                        break;
                    }
                    else
                    continue;
                }
                if(k[j]>0)//斜率大于0,在上方合理
                {
                    if((y-k[j]*x-b[j])>0)
                    {
                        p=1;
                        sum[j]+=1;
                        break;
                    }
                }
                if(k[j]<0)//斜率小于0,在下方合理
                {
                    if((y-k[j]*x-b[j])<0)
                    {
                        p=1;
                        sum[j]+=1;
                        break;
                    }
                }
*/

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值