BestCoder Round #2-TIANKENG’s restaurant

TIANKENG’s restaurant


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 
Input
  
  
The first line contains a positive integer T(T<=100), standing for T test cases in all. Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time. Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 
Output
  
  
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 
Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 
Sample Output
  
  
11 6
//AC
/*
做完这题顿时感觉自己好水
此题我用非常笨的方法做655MS过的,如果时间区间再大点估计就TE了
*/

#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iomanip>
#include<map>
#include<cstdlib>
#include<cmath>
#include<vector>
const int INF=0x7fffffff;
const double eps=1e-8;
const double PI=acos(-1.0);
const double inf=1e5;
const int Max=10010;
#define zero(x) (((x)>0?(x):-(x))<eps)
#define mm(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef struct TTime
{
    int hh;
    int mm;
}ttime;
typedef struct Customers
{
    ttime st;
    ttime et;
    int num_st;
    int num_et;
    int num;
}customers;
customers s[Max];
int DP[Max];
bool cmp_num( Customers a,Customers b)
{
    if(a.num_et==b.num_et)
    {
        if(a.num_st<b.num_st)
            return true;
    }
    else if(a.num_et<b.num_et)
    return true;
    return false;
}
int main()
{
    int m,i,j;
    int T,n;
    char a,b;
    int sum,time;
    cin>>T;
    while(T--)
    {
        cin>>n;
        sum=0;
        for(i=0;i<n;i++)
        {
            scanf("%d %d:%d %d:%d",&s[i].num,&s[i].st.hh,&s[i].st.mm,&s[i].et.hh,&s[i].et.mm);
            //cin>>s[i].num>>s[i].st.hh>>a>>s[i].st.mm>>s[i].et.hh>>b>>s[i].et.mm;
            s[i].num_st=s[i].st.hh*60+s[i].st.mm;
            s[i].num_et=s[i].et.hh*60+s[i].et.mm;
        }
        //sort(s,s+n,cmp_num);
        //sum=s[0].num;
        //time=s[0].num_et;
        //for(i=0;i<n;i++)
        //{
        //    cout<<s[i].num<<endl;
        //}

        mm(DP,0);
        for(i=0;i<n;i++)
        {
            for(j=s[i].num_st;j<s[i].num_et;j++)
            {
                DP[j]+=s[i].num;
                sum=max(sum,DP[j]);
            }
        }

        cout << sum << endl;
    }
    return 0;
}
/*
100
5
6 8:0 8:10
8 8:20 8:22
5 8:10 8:22
7 8:0 9:0
9 8:0 8:30

5
7 8:0 9:0
9 8:0 8:30
6 8:0 8:10
5 8:10 8:22
8 8:20 8:22
4
2 1:10 1:11
1 1:10 1:12
11 1:20 1:21
7 1:20 1:30

5
18 00:00 20:20
2 1:10 1:11
1 1:10 1:12
11 1:20 1:21
7 1:20 1:30

3
3
3 1:59 2:00
5 2:00 3:00
2 1:30 1:59
2
6 08:00 09:00
5 08:59 09:59
2
6 08:00 09:00
5 09:00 10:00
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值