题目的意思很好理解:就是给你很多的区间然后让你找出来区间内可以共同存在的最多的人数。
在来到到离开之前的这段时间内是算的,其他不算。
所以标记一下左右时间点,从左边加,到右边就减去了啊。不用每次更新整段区间。
TIANKENG’s restaurant
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)Total Submission(s): 423 Accepted Submission(s): 218
Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.
Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.
Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.
Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
Sample Input
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
Sample Output
11 6
Source
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-6
///#define M 1000100
#define LL __int64
///#define LL long long
#define INF 0x7fffffff
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)
const int maxn = 10010;
using namespace std;
struct node
{
int l, r;
int sum;
}f[maxn];
int sum[maxn];
int judge(int x, int y)
{
return 60*x+y;
}
int main()
{
int T;
cin >>T;
while(T--)
{
int n;
cin >>n;
int x1, y1, x2, y2;
memset(sum, 0, sizeof(sum));
for(int i = 0; i < n; i++)
{
scanf("%d",&f[i].sum);
scanf("%d:%d %d:%d",&x1, &y1, &x2, &y2);
f[i].l = judge(x1, y1);
f[i].r = judge(x2, y2);
sum[f[i].l] += f[i].sum;
sum[f[i].r] -= f[i].sum;
}
int Max = 0;
for(int i = 0; i <= 24*60; i++)
{
sum[i] += sum[i-1];
Max = max(sum[i], Max);
}
cout<<Max<<endl;
}
return 0;
}