杭电2141-Can you find it?

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 7800    Accepted Submission(s): 2025


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
 

Sample Output
Case 1:
NO
YES
NO
#include<iostream>
#include<algorithm>
const int MAX=501;
__int64 s[3][MAX];
__int64 A[300000];
using namespace std;
int main()
{
__int64 a,b,c,v,i,j,t,p,k;
int find(__int64 *A,int x,int y,int v);
int num;
k=1;
while(cin>>a>>b>>c)
{
for(i=0;i<a;i++)
scanf("%I64d",&s[0][i]);
for(i=0;i<b;i++)
scanf("%I64d",&s[1][i]);
for(i=0;i<c;i++)
scanf("%I64d",&s[2][i]);
for(i=0;i<a;i++)
{
for(j=0;j<b;j++)
{
A[i*b+j]=s[0][i]+s[1][j];
}
}
sort(A,A+a*b);//从小到大快排,形成二分的区间【x,y】
printf("Case %d:\n",k++);
scanf("%d",&num);
while(num--)
{
scanf("%d",&v);
p=0;
for(j=0;j<c;j++)
{
t=v-s[2][j];
p=find(A,0,a*b,t);
if(p)
break;
}
if(p)
printf("YES\n");
else
printf("NO\n");
}
}
return 0;
}
int find(__int64 *A,int x,int y,int v)
{
int mid; 
while(x<=y)
{
mid=(x+y)/2;
if(A[mid]==v)
return 1;
else if(A[mid]>v)
y=mid-1;
else if(A[mid]<v)
x=mid+1;
}
return 0;
}
/*
二分查找
int find(__int64 *A,int x,int y,int v)//是在[x,y]区间进行查找
{
    int m;
    while(x<=y)
    {
        m=(x+y)/2;
        if(A[m]==v)
            return 1;
        if(A[m]>v)
            y=m-1;
        if(A[m]<v)
            x=m+1;
    }
    return 0;
}*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值