杭电-2141 三个数组找定值(二分)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 23696    Accepted Submission(s): 5986


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2899  2289  1597  1010  2298 
 
解题思路:
这道题没做就感觉用三个循环肯定超时,于是看了别人的代码;
首先将前两个数组相加构成一个新的数组: dp[p]=a[i]+b[j];注意这里dp数组的大小
然后就将这个新数组加上另外一个数组和定值用二分法相比较 dp[mid]+c[k]==x
AC代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int l,n,m;
	int i,j,k,t;
	int a[1100];
	int b[1100];
	int c[1100];
	int s,x;
	int dp[310000];
	int q=0;
	while(scanf("%d%d%d",&l,&n,&m)!=EOF)
	{
		for(i=0;i<l;i++)
		   scanf("%d",&a[i]);
		for(j=0;j<n;j++)
		   scanf("%d",&b[j]);
		for(k=0;k<m;k++)
		   scanf("%d",&c[k]);
		int p=0;
		for(i=0;i<l;i++)
		  for(j=0;j<n;j++)
		    dp[p++]=a[i]+b[j];
	   sort(dp,dp+p);
	   printf("Case %d:\n",++q);
	   scanf("%d",&s);
	   while(s--)
	   {
	   	  scanf("%d",&x);
	   	  
	   	  int flag=1;
	   	  for(k=0;k<m;k++)
	   	  {
			  int l=0,r=p-1;
	   	      int mid;
	   	  	while(r>=l)
	   	  	{
	   	  		mid=(l+r)/2;
	   	  	 if(dp[mid]+c[k]==x)
	   	  	 {
	   	  	 	flag=0;
	   	  	    break;
			 }
			 if(dp[mid]+c[k]<x)
			 {
			 	l=mid+1;
			 }
			 if(dp[mid]+c[k]>x)
			 {
			 	r=mid-1;
			 } 
		   }
		     if(flag==0)
			 break;
		}  
		  if(flag==0)
		  printf("YES\n");
		  else
		  printf("NO\n");
	   	  
	   }	
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值