POJ1269-Intersecting Lines(判断两条直线平行、重合或者相交)

Intersecting Lines
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8789 Accepted: 3965

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT
这题大概意思就是在平面直角坐标给你两对(四个)点坐标A(x1,y1)和B(x2,y2),C(x3,y3)和D(x4,y4),让你计算直线A->B和直线C->D是平行(NONE)、重合(LINE)还是相交与一个点(POINT)如果相交就计算出相交点的坐标
这题方法纯粹是用数学知识,所以我们要根据四个点算出两条直线的斜率(K)和b,然后就判断
AC代码:
#include<iostream>
#include<cstdio>
#include<iomanip>
using namespace std;
double x1,x2,x3,x4,y1,y2,y3,y4,k1,k2,b1,b2,x,y;
int main()
{
    int n,i;
    while(cin>>n)
    {
        cout<<"INTERSECTING LINES OUTPUT"<<endl;
        for(i=0; i<n; i++)
        {
            cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4;
            if(x1!=x2&&x3!=x4)
            {
                k1=(y1-y2)/(x1-x2);//直线A->B的斜率
                k2=(y3-y4)/(x3-x4);//直线C->D的斜率
                b1=y1-(k1*x1);//直线A->B的b
                b2=y3-(k2*x3);//直线C->D的b
                if(k1==k2)//如果相等,表明不是平行就是重合
                {
                    if((x3*k1+b1)==y3)//如果直线C->D上点在直线A->B上表明两条直线重合了
                        cout<<"LINE"<<endl;
                    else//否则平行
                        cout<<"NONE"<<endl;
                }
                if(k1!=k2)//如果斜率不相等,表明斜率一定存在
                {
                    x=(b2-b1)/(k1-k2);
                    y=(k1*x)+b1;
                    cout<<"POINT ";
                    printf("%.2lf %.2lf\n",x,y);
                }
            }
            if(x1==x2||x3==x4)//考虑两条直线的斜率都不存在的情况
            {
                if(x1==x2&&x3==x4)//如果直线A->B和C->D的两个点横坐标相等
                {
                    if(x1==x3)//如果四个点都在同一条直线上
                        cout<<"LINE"<<endl;
                    else//否则就平行
                        cout<<"NONE"<<endl;
                }
                if(x1==x2&&x3!=x4)//下面两种情况是如果有一条直线斜率不存在而另一条直线存在
                {
                    k2=(y3-y4)/(x3-x4);
                    b2=y3-k2*x3;
                    y1=k2*x1+b2;
                    cout<<"POINT ";
                    printf("%.2lf %.2lf\n",x1,y1);
                }
                if(x1!=x2&&x3==x4)
                {
                    k1=(y1-y2)/(x1-x2);
                    b1=y1-k1*x1;
                    y3=k1*x3+b1;
                    cout<<"POINT ";
                    printf("%.2lf %.2lf\n",x3,y3);
                }
            }
        }
        cout<<"END OF OUTPUT"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值