2013 - ECJTU 暑期训练赛第七场-problem-G

C - O.O
Crawling in process... Crawling failed Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5
AC代码+解释:
/*
你求出了1~n与n互质的数之后,
把这些数加上n就可以得到
n~2n间的与n互质的数。
而且n~2n间不会有某个与n互质的数被漏掉。
因为如果n<=a<=2n,且gcd(a, n)==1,
那么gcd(a - n, n)必然等于1。
也就是必然有个在1~n间的数a-n,
可以通过加n的方式得到a。
所以与n互质的数是有周期性的。
我们只需要求出第一个周期即可。
*/
#include<iostream>
#include<string>
#include<cstring>
#include<iomanip>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<cstdio>
#include<cstdlib>
const int MAX=1000001;
int prim[MAX];
int m;
using namespace std;
int GCD(int x,int y)//求公约数
{
    if(y==0)
    return x;
    else
    return GCD(y,x%y);
}
int main()
{
    __int64 k;
    int i,j,n,t;
    prim[0]=1;
    while(cin>>m>>k)
    {
        n=1;
        for(i=2;i<=m;i++)
        {
            if(GCD(m,i)==1)
            {
                prim[n]=i;
                n++;
            }
        }
        if(k%n!=0)
        {
            t=k/n;
            cout<<m*t+prim[k%n-1]<<endl;
        }
        else
        {
            t=k/n-1;
            cout<<m*t+prim[n-1]<<endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值