2013 - ECJTU 暑期12级训练赛第一场-problem-E

E -E
Crawling in process... Crawling failed Time Limit:2000MS    Memory Limit:262144KB    64bit IO Format:%I64d & %I64u

Description

We know that prime numbers are positive integers that have exactly two distinct positive divisors. 

Similarly, we'll call a positive integer t Т-prime, if t has exactly three distinct positive divisors.

You are given an array of n positive integers. For each of them determine whether it is Т-prime or not.

Input

The first line contains a single positive integer,n (1 ≤ n ≤ 105), showing how many numbers are in the array. 

The next line contains n space-separated integersxi (1 ≤ xi ≤ 1012).

Please, do not use the %lld specifier to read or write 64-bit integers in С++. 

It is advised to use the cin, cout streams or the %I64d specifier.

Output

Print n lines: thei-th line should contain "YES" (without the quotes), if numberxi is Т-prime, and "NO" (without the quotes), if it isn't.

Sample Input

Input
3
4 5 6
Output
YES
NO
NO

Sample Output

Hint

The given test has three numbers. The first number 4 has exactly three divisors — 1, 2 and 4, thus the answer for this number is "YES".

 The second number 5 has two divisors (1 and 5), and the third number 6 has four divisors (1, 2, 3, 6), 

hence the answer for them is "NO".

这道题的解题思路是:先说下题意给出n个数,如果这其中的数有且仅有3个因子,那么输出YES其他输出NO,

这样想,如果这个数满足题意,

那么这个必定有两个因子是1个本身,

另一个则是自己开平方根且这个开平方根一定为素数(例如25,它的的因子有1,25还有自己开平方根5,

除此之外再也找不到其他因子,为什么开平方根一定为素数,

因为如果不为素数,那么一定找得到该平方根的倍数或者约数是这个数的因子,

例如16,因子为1,16,开平方根4,那么2和8也是16的因子),

所以想清楚这些,这道题不难AC了,

另外,这题判断书上时,要用sqrt判断不然会超时,还要哦按段输入的数是是否为1,1是特殊情况

AC代码:

#include<stdio.h>
#include<math.h>
int main()
{
__int64 s,m;
int prime(__int64 x);//判断是否为素数
int n;
scanf("%d",&n);
while(n--)
{
scanf("%I64d",&s);
if(s==1)//1是特殊情况,先判断输出
{
printf("NO\n");
continue;
}
m=sqrt(s);
if((m*m)!=s)
{
printf("NO\n");
continue;
}
else
{
if(prime(m))
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}
}
return 0;
}
int prime(__int64 x)
{
int i;
for(i=2;i<=sqrt(x);i++)//注意一定要用sqrt不然会超时
{
if(x%i==0)
return 0;
}
return 1;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值