UVa10115 - Automatic Editing- 字符串(子串替换)-难度2

题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=96&page=show_problem&problem=1056

Problem E: Automatic Editing

Source file:autoedit.{ccppjavapas}
Input file:autoedit.in
Output file:autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

RuleFindReplace-by
1.banbab
2.bababe
3.anaany
4.ba bhind the g

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because thefind string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

banana boat

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 BeforeAfter
banana boatbabana boat
babana boatbababa boat
bababa boatbeba boat
beba boatbehind the goat

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

Example output:

behind the goat
shoe or shop
代码+思路

/*
*注意点:
*1.string s,a; s = a; getline(cin, s)会把s清空后赋值
*2.自己写个找子串的函数
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
using namespace std;


int find_str(const string &a, const string &b)
{//判断b是否是a的子串,是返回第一个出现的位置,否返回-1
	int alen = a.size();
	int blen = b.size();
	if(alen < blen) return -1;
	else
	{
		for(int i = 0; i <= alen - blen; ++i)
		{
			int flag = 0;
			for(int j = 0; j < blen; j++)
			{
				if(a[i + j] != b[j])
				{
					flag = 1;
					break;//flag = 1表示这个字母开始不会是子串
				}
			}
			if(flag == 0) return i;//flag = 1表示a[i]字母开始是子串,返回i的位置
		}
	}
	return -1;
}
int main()
{
#ifdef LOCAL
	freopen("f:\\input.txt", "r", stdin);
	//freopen("f:\\output.txt", "w", stdout);
#endif
	
	int  n;
	while(cin >> n)
	{
		if(n == 0) break;
		getchar();//去回车
		string s;
		vector<string> v1, v2;
		while(n--)
		{
			getline(cin, s);
			v1.push_back(s);
			getline(cin, s);
			v2.push_back(s);
		}
		getline(cin, s);//以上把一组测试数据读入
		for(int i = 0; i != v1.size(); ++i)
		{
			int pos;
			while(1)
			{
				pos = find_str(s, v1[i]);
				if(pos == -1) break;
				else
				{
					string temp;//用temp暂存s
					for(int j = 0; j != pos; ++j)
					{
						temp.push_back(s[j]);
					}

					for(int j = 0; j != v2[i].size(); ++j)
					{
						temp.push_back(v2[i][j]);
					}
					for(int j = pos + v1[i].size(); j < s.size(); j++)
					{
						temp.push_back(s[j]);
					}//上面的循环终止条件要仔细判断
					s = temp;
				}
			
			}
		}
		cout << s << endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值