zoj2977Strange Billboard (状态压缩+枚举)

Strange Billboard

Time Limit: 2 Seconds Memory Limit: 65536 KB

The marketing and public-relations department of the Czech Technical University has designed a new reconfigurable mechanical Flip-Flop Bill-Board (FFBB). The billboard is a regular two-dimensional grid of R * C square tiles made of plastic. Each plastic tile is white on one side and black on the other. The idea of the billboard is that you can create various pictures by flipping individual tiles over. Such billboards will hang above all entrances to the university and will be used to display simple pictures and advertise upcoming academic events.

To change pictures, each billboard is equipped with a "reconfiguration device". The device is just an ordinary long wooden stick that is used to tap the tiles. If you tap a tile, it flips over to the other side, i.e., it changes from white to black or vice versa. Do you agree this idea is very clever?

Unfortunately, the billboard makers did not realize one thing. The tiles are very close to each other and their sides touch. Whenever a tile is tapped, it takes all neighboring tiles with it and all of them flip over together. Therefore, if you want to change the color of a tile, all neighboring tiles change their color too. Neighboring tiles are those that touch each other with the whole side. All inner tiles have 4 neighbors, which means 5 tiles are flipped over when tapped. Border tiles have less neighbors, of course.

For example, if you have the billboard configuration shown in the left picture above and tap the tile marked with the cross, you will get the picture on the right. As you can see, the billboard reconfiguration is not so easy under these conditions. Your task is to find the fastest way to "clear" the billboard, i.e., to flip all tiles to their white side.

Input

The input consists of several billboard descriptions. Each description begins with a line containing two integer numbers R and C (1 <= R,C <= 16) specifying the billboard size. Then there are R lines, each containing C characters. The characters can be either an uppercase letter "X" (black) or a dot "." (white). There is one empty line after each map. The input is terminated by two zeros in place of the board size.

Output

For each billboard, print one line containing the sentence "You have to tap T tiles.", where T is the minimal possible number of taps needed to make all squares white. If the situation cannot be solved, output the string "Damaged billboard." instead.

Sample Input

5 5
XX.XX
X.X.X
.XXX.
X.X.X
XX.XX

5 5
.XX.X
.....
..XXX
..X.X
..X..

1 5
...XX

5 5
...X.
...XX
.XX..
..X..
.....

8 9
..XXXXX..
.X.....X.
X..X.X..X
X.......X
X.X...X.X
X..XXX..X
.X.....X.
..XXXXX..

0 0

Sample Output

You have to tap 5 tiles.
Damaged billboard.
You have to tap 1 tiles.
You have to tap 2 tiles.
You have to tap 25 tiles.
题意:用最少的翻转把所有的X变成点。每翻第(x,y)点同时也会带动周围四个点。
解法:枚举第一行的翻转状态,根据第i-1行翻转第i行。
#include<stdio.h>
#include<iostream>
using namespace std;
#define mulit(j) (1<<j)
#define inf 999999999
int row[18],trow[18],n,m;
int dfs(int i,int prerow,int step)
{
    if(i==n)
    {
        if(prerow)return inf; else return step;
    }
    int now=trow[i],j;
    for(j=0;j<m;j++)
    if(prerow&(1<<j))
    {
        step++;  now^=mulit(j);
        if(j>0)now^=mulit(j-1);
        if(j<m-1)now^=mulit(j+1);
        if(i+1<n)trow[i+1]^=mulit(j);
    }
   return dfs(i+1,now,step);
}
void answer()
{
    int MIN=inf,step;
    for(int i=0;i<(1<<m);i++)
    {
        step=0;
        for(int j=0;j<n;j++)
        trow[j]=row[j];
        for(int j=0;(1<<j)<=i;j++)
        if(i&(1<<j))
        {
            step++; trow[0]^=(1<<j);
            if(j>0)trow[0]^=(1<<(j-1));
            if(j<m-1)trow[0]^=(1<<(j+1));
            if(n>1) trow[1]^=(1<<j);
        }
        step=dfs(1,trow[0],step);
        if(step<MIN)MIN=step;
    }
    if(MIN==inf)printf("Damaged billboard.\n");
    else printf("You have to tap %d tiles.\n",MIN);
}
int main()
{
    char ss[18];
    while(scanf("%d%d",&n,&m)>0&&n+m!=0)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%s",ss);
            row[i]=0;
            for(int j=0;j<m;j++)
            if(ss[j]=='X')
                row[i]|=(1<<j);
        }
       answer();
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值