HNU13033Football (贪心)

Football
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:65536KB
Total submit users: 19, Accepted users: 17
Problem 13033 : No special judgement
Problem description
Your favorite football team is playing a charity tournament, which is part of a worldwide fundraising e ort to help children with disabilities. As in a normal tournament, three points are awarded to the team winning a match, with no points to the losing team. If the game is drawn, each team receives one point.
Your team played N matches during the first phase of the tournament, which has just finished. Only some teams, the ones with more accumulated points, will advance to the second phase of the tournament. However, as the main objective of the tournament is to raise money, before the set of teams that will pass to the second phase is determined, each team is allowed to buy additional goals. These new goals count as normally scored goals, and may be used to alter the result of any of the matches the team played.
Your team's budget is enough to buy up to G goals. Can you tell the maximum total number of points your team can get after buying the goals, supposing the other teams will not buy any goals?
Input
The first line contains two integers N (1 ≤ N ≤ 105) and G (0 ≤ G ≤ 106) representing respectively the number of matches your team played and the number of goals your team can buy. Each of the next N lines describes a match result with two integers S and R (0 ≤ S;R ≤ 100), indicating respectively the goals your team scored and received on that match before buying goals.
Output
For each test case, output a line with an integer representing the maximum total number of points your team can get after buying the goals.
Sample Input
Sample input 1
2 1
1 1
1 1

Sample input 2
3 2
1 3
3 1
2 2

Sample input 3
4 10
1 1
2 2
1 3
0 4
Sample Output
Sample output 1
4

Sample output 2
6

Sample output 3
12
Problem Source

ICPC Latin American Regional 2013

题意:给出N场比赛的每场比分s:r, s是本队得分,从开始手里有G个比分,可以分给每一场比分,赢了则加3个点,平局加1个点。输了得0个点。再问最多能得多少个点。

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
bool cmp(int a,int b){return a>b;}
int main()
{
    int sum,N,G,sub[100005],s,r,k,m,ss;
    while(scanf("%d%d",&N,&G)>0)
    {
        sum=0;k=0;m=0; ss=0;
        for(int i=0;i<N;i++)
        {
            scanf("%d%d",&s,&r);
           if(s-r<0) sub[k++]=s-r;
           else if(s-r==0)m++;
           else ss+=3;
        }
        
        sort(sub,sub+k,cmp);
        for(int j=0;j<=m&&j<=G;j++)
        {
            int s=m-j+j*3+ss,g=G-j;
            for(int i=0;i<k;i++)
            if(-sub[i]<g)
            {
                g+=sub[i]-1;s+=3;
            }
            else if(-sub[i]==g)
            g+=sub[i],s++;
            else break;
            if(s>sum)sum=s;
        }
        printf("%d\n",sum);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值