HUD3038How Many Answers Are Wrong(并查集)经典

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3063    Accepted Submission(s): 1181


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
  
  
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

Sample Output
  
  
1
 

Source
看了他人的解题报告才知道并查集还可以这样应用,下面是引用一下,因为感觉写得很清楚了,就直接拿过来:

题目大意:有n次询问,给出a到b区间的总和,问这n次给出的总和中有几次是和前面已近给出的是矛盾的??

做了好长时间了,现在整理一下

首先说明的是,这个是并查集的一种应用,刚开始的时候我还以为是线段树之类的东西呢。但是苦思无解,最后还是看了解题报告,原来是并查集,看完解题报告,我发现,有一组数据我一直想不明白,

10 3
1 2 2
3 4 2
2 4 100

我以为1到2和为2,3到4和为2,2到4和不会超过4呢!!哎,这么傻怎么还弄acm呢?呜呜,在这儿感谢新浪的Jopix给我指点。(-98,100,1, 1)


言归正传,说说这个题的思路。首先,

如果我们知道a到b之间的关系,a到c之间的关系,那么我们就可以知道a,b,c任意两个之间的关系,如果我们再知道了d和c之间的关系,那么我们就知道了a,b,c,d之间的关系,但是怎么表示这些关系呢??我们用的是并查集,顺便加一个每一个节点到根的距离,这样的话,任意两个点之间关系就可以通过求与根的距离求差得出,也就是说,如果输入的n,m在一个集合里,那么我们判断这两个的关系是否和已有的冲突,如果n,m不在一个集合里,那么我们就合并这两个集合,是的n,m这两个所在的两个集合之间的任意元素都有关系。

#include<stdio.h>

const int N = 200005;

int fath[N],sum[N],n;

void init()
{
    for(int i=0;i<=n;i++)
    {
        fath[i]=i; sum[i]=0;
    }
}
int findfath(int x)
{
    if(x!=fath[x])
    {
        int f=fath[x];
        fath[x]=findfath(fath[x]);
        sum[x]+=sum[f];
    }
    return fath[x];
}
int setfath(int x,int y,int s)
{
    int tx=findfath(x);
    int ty=findfath(y);
    if(tx==ty&&sum[x]!=sum[y]+s)
       return 1;
    else if(tx!=ty)
    {
        if(tx>ty)
        {
            fath[ty]=tx; sum[ty]=sum[x]-sum[y]-s;
        }
        else
        {
            fath[tx]=ty; sum[tx]=sum[y]+s-sum[x];
        }
    }
    return 0;
}
int main()
{
    int m,a,b,s,ans;
    while(scanf("%d%d",&n,&m)>0)
    {
        init();
        ans=0;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&s);
            a--;
            ans+=setfath(a,b,s);
        }
        printf("%d\n",ans);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值