CSU1569: Wet Tiles(BFS控制时间相同)

1569: Wet Tiles

Time Limit: 60 Sec   Memory Limit: 512 MB
Submit: 73   Solved: 34
[ Submit][ Status][ Web Board]

Description

Alice owns a construction company in the town of Norainia, famous for its unusually dry weather. In fact, it only rains a few days per year there. Because of this phenomenon, many residents of Norainia neglect to do roof repairs until leaks occur and ruin their floors. Every year, Alice receives a deluge of calls from residents who need the leaks fixed and floor tiles replaced. While exquisite in appearance, Norainia floor tiles are not very water resistant; once a tile becomes wet, it is ruined and must be replaced. This year, Alice plans to handle the rainy days more efficiently than in past years. She will hire extra contractors to dispatch as soon as the calls come in, so hopefully all leaks can be repaired as soon as possible. For each house call, Alice needs a program to help her determine how many replacement tiles a contractor team will need to bring to complete the job.

For a given house, square floor tiles are arranged in a rectangular grid. Leaks originate from one or more known source locations above specific floor tiles. After the first minute, the tiles immediately below the leaks are ruined. After the second minute, water will have spread to any tile that shares an edge with a previously wet tile. This pattern of spreading water continues for each additional minute. However, the walls of a house restrict the water; if a damaged area hits a wall, the water does not penetrate the wall. We assume there are always four outer walls surrounding the entire house. A house may also have a number of additional "inner" walls; each inner wall is comprised of a connected linear sequence of locations (which may or may not be connected to the outer walls or to each other).

As an example, Figure 1 shows water damage (in gray) that would result from three initial leaks (each marked with a white letter 'L') after each of the first five minutes of time. Tiles labeled '2' become wet during the second minute, tiles labeled '3' become wet during the third minute, and so forth. The black areas designate inner walls that restrict the flow of water. Note that after 5 minutes, a total of 75 tiles have been damaged and will need to be replaced. Figures 2 through 4 show other houses that correspond to the example inputs for this problem.

75 wet tiles

17 wet tiles

4 wet tiles

94 wet tiles

Input

 Each house is described beginning with a line having five integral parameters: X Y T L W. Parameters X and Y designate the dimensions of the rectangular grid, with 1 ≤ X ≤ 1000 and 1 ≤ Y ≤ 1000. The coordinate system is one-indexed, as shown in the earlier figures. Parameter T designates the number of minutes that pass before a team of contractors arrives at a house and stops the leaks, with 1 ≤ T ≤ 200000. The parameter L designates the number of leaks, with 1 ≤ L ≤ 100. Parameter W designates the number of inner walls in the house, 0 ≤ W ≤ 100.

The following 2L integers in the data set, on one or more lines, are distinct (x y) pairs that designate the locations of the L distinct leaks, such that 1 ≤ x ≤ X and 1 ≤ y ≤ Y.

If W > 0, there will be 4W additional integers, on one or more lines, that describe the locations of the walls. For each such wall the four parameters (x1,y1), (x2,y2) describe the locations of two ends of the wall. Each wall replaces a linear sequence of adjoining tiles and is either axis-aligned or intersects both axes at a 45 degree angle. Diagonal walls are modeled as a sequence of cells that would just be touching corner to corner. If the two endpoints of a wall are the same, the wall just occupies the single cell at that location. Walls may intersect with each other, but no leak is over a wall.

There will be one or more houses in the data file and a line with a single integer -1 designates the end of the data set.

Output

 For each house, display the total number of tiles that are wet after T minutes.

Sample Input

12 12 5 3 5
2 11 3 3 9 5
1 9 6 9 1 7 4 4 7 1 7 4
10 9 10 12 11 4 12 4
9 7 8 1 3
4 3
2 2 6 6 6 2 2 6 8 2 8 2
6 7 50 1 3
3 4
2 2 2 6 3 6 5 4 5 4 3 2
12 12 5 3 0
2 11 3 3 9 5
-1

Sample Output

75
17
4
94

HINT

Source

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int N = 1005;
struct locate
{
    int x,y;
};
int mapt[N][N],n,m,T,dir[4][2]={0,1,0,-1,1,0,-1,0};
queue<locate>q[2];
void bfs(int flag)
{
    locate pre,now;
    while(!q[flag].empty())
    {
        pre=q[flag].front();q[flag].pop();
        for(int e=0;e<4;e++)
        {
            now.x=pre.x+dir[e][0];
            now.y=pre.y+dir[e][1];
            if(now.x>0&&now.x<=n&&now.y>0&&now.y<=m&&mapt[now.x][now.y]==0)
            {
                mapt[now.x][now.y]=1;
                q[!flag].push(now);
            }
        }
    }
}
int main()
{
    int L,W;
    locate now,pre;
    while(scanf("%d",&n)>0&&n!=-1)
    {
        scanf("%d%d%d%d",&m,&T,&L,&W);
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        mapt[i][j]=0;
        while(!q[0].empty())q[0].pop();
        while(!q[1].empty())q[1].pop();
        while(L--)
        {
            scanf("%d%d",&now.x,&now.y); q[0].push(now);
        }
        while(W--)
        {
            scanf("%d%d%d%d",&pre.x,&pre.y,&now.x,&now.y);
            if(now.x>pre.x)
            {
                int tt;
                tt=pre.x; pre.x=now.x; now.x=tt;
                tt=pre.y; pre.y=now.y; now.y=tt;
            }
            if(pre.x==now.x)
            {
                if(pre.y<now.y)
                {
                    int tt=pre.y; pre.y=now.y; now.y=tt;
                }
                while(pre.y>=now.y)
                {
                    mapt[pre.x][pre.y--]=2;
                }
            }
            else if(pre.y==now.y)
            {
                if(pre.x<now.x)
                {
                    int tt=pre.x; pre.x=now.x; now.x=tt;
                }
                while(pre.x>=now.x)
                {
                    mapt[pre.x--][pre.y]=2;
                }
            }
            else if(pre.x>=now.x&&pre.y<=now.y)
            {
                while(now.x<=pre.x&&now.y>=pre.y)
                {
                    mapt[now.x][now.y]=2;
                    now.y--; now.x++;
                }
            }
            else
            {
                while(now.x<=pre.x&&now.y<=pre.y)
                {
                    mapt[pre.x][pre.y]=2;
                    pre.y--; pre.x--;
                }
            }
        }

        int flag=0;
        while(!q[flag].empty())
        {T--;
            if(T==0) break;

            bfs(flag); flag=!flag;
        }
        int ans=0;
        for(int j=m;j>=1;j--)
        {
            for(int i=1;i<=n;i++)
            {
                //printf("%d ",mapt[i][j]);
                if(mapt[i][j]==1)
                ans++;
            }
            //printf("\n");
        }


        printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值