HDU 5280 Senior's Array

Senior's Array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 528    Accepted Submission(s): 209


Problem Description
One day, Xuejiejie gets an array A . Among all non-empty intervals of A , she wants to find the most beautiful one. She defines the beauty as the sum of the interval. The beauty of the interval--- [L,R] is calculated by this formula : beauty(L,R) = A[L]+A[L+1]++A[R] . The most beautiful interval is the one with maximum beauty.

But as is known to all, Xuejiejie is used to pursuing perfection. She wants to get a more beautiful interval. So she asks Mini-Sun for help. Mini-Sun is a magician, but he is busy reviewing calculus. So he tells Xuejiejie that he can just help her change one value of the element of A to P . Xuejiejie plans to come to see him in tomorrow morning.

Unluckily, Xuejiejie oversleeps. Now up to you to help her make the decision which one should be changed(You must change one element).
 

Input
In the first line there is an integer T , indicates the number of test cases.

In each case, the first line contains two integers n and P . n means the number of elements of the array. P means the value Mini-Sun can change to.

The next line contains the original array.

1n1000 , 109A[i],P109
 

Output
For each test case, output one integer which means the most beautiful interval's beauty after your change.
 

Sample Input
  
  
2 3 5 1 -1 2 3 -2 1 -1 2
 

Sample Output
  
  
8 2
 

Source
题意: 给一个数组a[n],问使数组中某一个值变成P,得到a[l]+a[l+1]+......+a[r]最大是多少。
#include<stdio.h>
const int N = 1005;
const int inf = 1<<29;
int main(){
    __int64 dp[N],P,a[N],ans;
    int n,T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%I64d",&n,&P);
        for(int i=1; i<=n; i++)
            scanf("%I64d",&a[i]);

        ans=-inf;
        dp[0]=0;

        for(int i=1; i<=n; i++)
        {
            int tmp=a[i];
            a[i]=P;
            for(int j=1; j<=n; j++)
            {
                if(dp[j-1]>0)
                    dp[j]=dp[j-1]+a[j];
                else
                    dp[j]=a[j];
                if(dp[j]>ans)
                    ans=dp[j];
            }
            a[i]=tmp;
        }
        printf("%I64d\n",ans);
    }
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值