HDU 5281 Senior's Gun

Senior's Gun

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 616    Accepted Submission(s): 241


Problem Description
Xuejiejie is a beautiful and charming sharpshooter.

She often carries n guns, and every gun has an attack power a[i] .

One day, Xuejiejie goes outside and comes across m monsters, and every monster has a defensive power b[j] .

Xuejiejie can use the gun i to kill the monster j , which satisfies b[j]a[i] , and then she will get a[i]b[j] bonus .

Remember that every gun can be used to kill at most one monster, and obviously every monster can be killed at most once.

Xuejiejie wants to gain most of the bonus. It's no need for her to kill all monsters.
 

Input
In the first line there is an integer T , indicates the number of test cases.

In each case:

The first line contains two integers n , m .

The second line contains n integers, which means every gun's attack power.

The third line contains m integers, which mean every monster's defensive power.

1n,m100000 , 109a[i],b[j]109
 

Output
For each test case, output one integer which means the maximum of the bonus Xuejiejie could gain.
 

Sample Input
  
  
1 2 2 2 3 2 2
 

Sample Output
  
  
1
 

Source
 

题意:

有n把枪,m只怪物,每把抢都有一个能量值,每个怪物都有一个耗能值,现在用n把枪去打怪物,每把枪只能用一次,怪物只能打一次,用每i把枪打第j只怪物得到能量值为a[i]-b[j],前提a[i]>=b[j],枪可以不用完,怪物也可以不打完,问最多能得多少的能量值。
解题:枚举用k把枪去打k只怪物,那么每把枪都是最大能量值,每只怪物都是耗能最少的。
<pre name="code" class="cpp">#include<stdio.h>
#include<algorithm>
using namespace std;
const int N = 100005;
bool cmp(int a,int b){
    return a>b;
}
__int64 ans,a[N],b[N];
int main()
{
    
    int T,n,m;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%I64d",&a[i]);
        for(int i=0; i<m; i++)
            scanf("%I64d",&b[i]);
        sort(a,a+n,cmp);
        sort(b,b+m);
        int k=0;
        ans=-(1<<29);
        while(k<n&&k<m){
            if(k!=0){
                a[k]+=a[k-1];
                b[k]+=b[k-1];
            }
            if(ans<a[k]-b[k])
                ans=a[k]-b[k];
            k++;
        }
        printf("%I64d\n",ans);
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值