HNU Cent Savings (DP)

Cent Savings
Time Limit: 5000ms, Special Time Limit:12500ms, Memory Limit:65536KB
Total submit users: 54, Accepted users: 36
Problem 13345 : No special judgement
Problem description

To host a regional contest like NWERC a lot of preparation is necessary: organizing rooms and computers, making a good problem set, inviting contestants, designing T-shirts, book- ing hotel rooms and so on. I am responsible for going shopping in the supermarket.

When I get to the cash register, I put all my n items on the conveyor belt and wait until all the other customers in the queue in front of me are served. While waiting, I realize that this supermarket recently started to round the total price of a purchase to the nearest multiple of 10 cents (with 5 cents being rounded upwards). For example, 94 cents are rounded to 90 cents, while 95 are rounded to 100.

It is possible to divide my purchase into groups and to pay for the parts separately. I managed to find d dividers to divide my purchase in up to d + 1 groups. I wonder where to place the dividers to minimize the total cost of my purchase. As I am running out of time, I do not want to rearrange items on the belt.


Input

The input consists of:

• one line with two integers n (1 ≤ n ≤ 2000) and d (1 ≤ d ≤ 20), the number of items and the number of available dividers;

• one line with n integers p1,...pn(1 ≤ pi≤ 10000 for 1 ≤ i ≤ n), the prices of the items in cents. The prices are given in the same order as the items appear on the belt.


Output

Output the minimum amount of money needed to buy all the items, using up to d dividers.


Sample Input
5 1
13 21 55 60 42
5 2
1 1 1 1 1
Sample Output
190
0
#include<stdio.h>
#include<string.h>
const int N = 2005;
int main()
{
    int dp[N][25],n,d,sum[N];
    while(scanf("%d%d",&n,&d)>0)
    {
        for(int i=0; i<=n; i++)
            for(int j=1; j<=d; j++)
             dp[i][j]=1<<29;
        for(int j=0; j<=d; j++)
             dp[0][j]=0;
        sum[0]=0;
        for(int i=1; i<=n; i++){
            scanf("%d",&sum[i]);
            sum[i]+=sum[i-1];
        }
        for(int i=1; i<=n; i++)
            if(sum[i]%10>4)
                dp[i][0]=sum[i]-sum[i]%10+10;
            else
                dp[i][0]=sum[i]-sum[i]%10;

        for(int i=1; i<=n; i++)
        for(int j=1; j<=d; j++)
        for(int ti=i-1; ti>=0; ti--)
        {
            int ad=sum[i]-sum[ti];
            if(ad%10>4){
                ad=ad-ad%10+10;
            }
            else ad=ad-ad%10;
            if(dp[i][j]>dp[ti][j-1]+ad)
                dp[i][j]=dp[ti][j-1]+ad;
        }
        printf("%d\n",dp[n][d]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值