hdu1200(来来回回串起来)

Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input
   
   
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0

Sample Output
   
   
theresnoplacelikehomeonasnowynightx thisistheeasyoneab
#include<stdio.h>
#include<string.h>
int main()
{
    int n,i,len,m,e,j;
    char str[10000],ch[1000][25];
    while(scanf("%d",&n)==1&&n)
    {
        getchar();
        scanf("%s",str);
        len=strlen(str);
        m=len/n;//把str串分成m个小串
        if(len%n)
        m++;
        for(i=0;i<m;i++)
        if(i%2==0)//当能被2整除的就正向保存
        {
            e=0;
             for(j=i*n;j<len&&j<(i+1)*n;j++)
                ch[i][e++]=str[j];
        }
        else//否则就倒着保存
        {
            e=0;
            for(j=(i+1)*n-1;j>=i*n;j--)
            if(str[j]!='\0')
            ch[i][e++]=str[j];
        }
        e=len%n;//注意,有的不能除尽,最后一个小串长度小于n
        for(j=0;j<n;j++)
        for(i=0;i<m;i++)
        if(i==m-1)//最后一个小串输出
        {
            if(j<e||e==0)
            printf("%c",ch[i][j]);
        }
        else
        printf("%c",ch[i][j]);

        printf("\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值