hdu1205(类似 分布垃圾数列)

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input
Each line will contain an integers. Process to end of file.

Output
For each case, output the result in a line.

Sample Input
  
  
100

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int f[7050][500],len[1000],i,j,e,c,n;

int main()
{
    memset(f,0,sizeof(f));
    f[1][0]=f[2][0]=f[3][0]=f[4][0]=1;
    len[1]=len[2]=len[3]=len[4]=1;
    for(i=5;i<7050;i++)
    {
        c=0;
        for(j=0;j<500;j++)
        {
                f[i][j]=f[i-1][j]+f[i-2][j]+f[i-3][j]+f[i-4][j]+c;
                c=f[i][j]/100000000;//这样可以节少空间的使用
                f[i][j]%=100000000;
        }
    }

    while(cin>>n)
    {
        for(e=499;e>=0;e--)
        if(f[n][e])
        break;
        printf("%d",f[n][e--]);
        for(;e>=0;e--)
        printf("%08d",f[n][e]);//一定要注意补0,因为在上面取余时,如21000003234498%10000000=3234498
        cout<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值