hdu1010(深搜 +剪枝)

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

Sample Output
  
  
NO YES
#include<iostream>
using namespace std;

int escape,time,t,di,dj;//di,dj是出口位置,t是过了t时,
char map[8][8];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};//向右,左,上,下

int abs(int a)
{
    if(a<0)
    a=-a;
    return a;
}

void DFS (int i,int j)
{
    int k,step;
    char ch;
    step=abs(di-i)+abs(dj-j);//从当前位到D的至少要走step步
    if(time-t<step)//如果余下的时间 time-t 小于至少要走的步数,一定不会在所要求的时间内到达
        return ;   //那么在当前的位置就不用往下走
        
    for(k=0;k<4;k++)//走了方向
    if(map[i+dir[k][0]][j+dir[k][1]]!='X')
    {
        t++; ch=map[i+dir[k][0]][j+dir[k][1]];
        if(t==time&&map[i+dir[k][0]][j+dir[k][1]]=='D')
        {
            escape=1; return ;
        }
        else if(t==time)
        {
            t--; return ;
        }
        map[i+dir[k][0]][j+dir[k][1]]='X';
        DFS(i+dir[k][0],j+dir[k][1]);
        
        if(escape)//如果是真就走出来了,就不用浪费时间再走下去了,直接全部跳出来
        return ;
        map[i+dir[k][0]][j+dir[k][1]]=ch;//往回退,还原
        t--;
    }
}
int main()
{
    int si,sj,x,m,n,i,j;
    while(cin>>n>>m>>time&&(n||m||time))
    {
        x=0; escape=0; t=0;
        for(i=0;i<=n+1;i++)
        for(j=0;j<=m+1;j++)
        if(i>0&&i<=n&&j>0&&j<=m)
        {
            cin>>map[i][j];

            if(map[i][j]=='X')
                x++;
            if(map[i][j]=='S')
            {
                si=i;sj=j;
            }
            if(map[i][j]=='D')
            {
                di=i;dj=j;
            }
        }
        else
        map[i][j]='X';

        if(n*m-x-1<time)//除去墙以外都走的步数小于在指定的时间
        {
            cout<<"NO"<<endl;
            continue;
        }
        if((si+sj)%2==0&&(di+dj)%2==1&&time%2==0)//从偶位置走到奇位置要走奇数步
        {
            cout<<"NO"<<endl;
            continue;
        }
        if((si+sj)%2==1&&(di+dj)%2==0&&time%2==0)//从奇位置走到偶位置要走奇数步
        {
            cout<<"NO"<<endl;
            continue;
        }
        if((si+sj)%2==0&&(di+dj)%2==0&&time%2==1)//从偶位置走到偶位置要走偶数步
        {
            cout<<"NO"<<endl;
            continue;
        }
        if((si+sj)%2==1&&(di+dj)%2==1&&time%2==1)//从奇位置走到奇位置要走偶数步
        {
            cout<<"NO"<<endl;
            continue;
        }
        map[si][sj]='X';
        DFS(si,sj);
        if(escape)
        cout<<"YES"<<endl;
        else
        cout<<"NO"<<endl;
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值