易语言基础——读写文件

1.实现效果

1.打开文件;
2.保存文件;
3.根据一定的规则切割展示文本内容;

这里写图片描述

2.源码

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 程序集_读入的字节集, 字节集

.子程序 _打开文件_被选择
.局部变量 临时_文件路径, 文本型
.局部变量 i, 整数型
.局部变量 临时_文件内容, 文本型
.局部变量 临时_分割每行文本, 文本型, , "0"
.局部变量 临时_分割文本, 文本型, , "0"
.局部变量 临时_索引, 整数型

.如果真 (通用对话框1.打开 ())
    ' 如果用户选择了打开某个文件 执行以下操作
    临时_文件路径 = 通用对话框1.文件名
    程序集_读入的字节集 = 读入文件 (临时_文件路径)

    临时_文件内容 = 到文本 (程序集_读入的字节集)

    临时_分割每行文本 = 分割文本 (临时_文件内容, #换行符, )

    .计次循环首 (取数组成员数 (临时_分割每行文本), i)
        临时_分割文本 = 分割文本 (临时_分割每行文本 [i], “----”, )
        临时_索引 = 超级列表框1.插入表项 (-1, 到文本 (i), , , , )
        超级列表框1.置标题 (临时_索引, 1, 临时_分割文本 [1])
        超级列表框1.置标题 (临时_索引, 2, 临时_分割文本 [2])
    .计次循环尾 ()
.如果真结束


.子程序 _保存文件_被选择


.如果真 (通用对话框2.打开 ())
    写到文件 (通用对话框2.文件名, 程序集_读入的字节集)
.如果真结束

发布了118 篇原创文章 · 获赞 89 · 访问量 38万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览