579 - ClockHands

 ClockHands 

The medieval interest in mechanical contrivances is well illustrated by the development ofthe mechanical clock, the oldest of which is driven by weights and controlled by a verge, anoscillating arm engaging with a gear wheel. It dates back to 1386.

Clocks driven by springs had appeared by the mid-15th century, making it possible to con-struct more compact mechanisms and preparing the way for the portable clock.

English spring-driven pendulum clocks were first commonly kept on a small wall bracketand later on a shelf. Many bracket clocks contained a drawer to hold the winding key. Theearliest bracket clocks, made for a period after 1660, were of architectural design, with pillarsat the sides and a pediment on top.

In 17th- and 18th-century France, the table clock became an object of monumental design,the best examples of which are minor works of sculpture.

The longcase clocks (also called grandfather clocks) are tall pendulum clock enclosed in awooden case that stands upon the floor and is typically from 6 to 7.5 feet (1.8 to 2.3 m) in height.Later, the name ``grandfather clock'' became popular after the popular song "My Grandfather'sClock," written in 1876 by Henry Clay Work.


One of the first atomic clocks was an ammonia-controlled clock. It was built in 1949 at theNational Bureau of Standards, Washington, D.C.; in this clock the frequency did not vary bymore than one part in 108

Nuclear clocks are built using two clocks. The aggregate of atoms that emit the gammaradiation of precise frequency may be called the emitter clock; the group of atoms that absorbthis radiation is the absorber clock. One pair of these nuclear clocks can detect energy changesof one part in 1014 , being about 1,000 times more sensitive than the best atomic clock.

The cesium clock is the most accurate type of clock yet developed. This device makes useof transitions between the spin states of the cesium nucleus and produces a frequency whichis so regular that it has been adopted for establishing the time standard.


The history of clocks is fascinating, but unrelated to this problem. In this problem, youare asked to find the angle between the minute hand and the hour hand on a regular analogclock. Assume that the second hand, if there were one, would be pointing straight up at the12. Give all angles as the smallest positive angles. For example 9:00 is 90 degrees; not -90 or270 degrees.

Input 

The input is a list of times in the form H : M, each on their own line, with $1 \le H \le 12$and $00 \le M \le 59$.The input is terminated with the time 0:00. Note that H may be represented with1 or 2 digits (for 1-9 or 10-12, respectively); M is always represented with 2 digits(The input times are what you typically see on a digital clock).

Output 

The output displays the smallest positive angle in degrees between the hands for each time.The answer should between 0 degrees and 180 degrees for all input times. Display each angleon a line by itself in the same order as the input. The output should be rounded to the nearest1/1000, i.e., three places after the decimal point should be printed.

Sample Input 

12:00
9:00
8:10
0:00

Sample Output 

0.000
90.000
175.000
#include<stdio.h>
#include<math.h>
int main()
{
	double h,m,ans;
	while(scanf("%lf:%lf",&h,&m))
	{
		if(!h&&!m) break;
		h=(h+m/60)*30;
		m*=6;
		ans=fabs(h-m);
		printf("%.3f\n",ans<=180?ans:360-ans);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值