10285 - Longest Run on a Snowboard

Problem C

Longest Run on a Snowboard

Input:standard input

Output:standard output

Time Limit: 5 seconds

Memory Limit: 32 MB

 

Michael likes snowboarding. That'snot very surprising, since snowboarding is really great. The bad thing is that inorder to gain speed, the area must slide downwards. Another disadvantage isthat when you've reached the bottom of the hill you have to walk up again orwait for the ski-lift.

Michaelwould like to know how long the longest run in an area is. That area is givenby a grid of numbers, defining the heights at those points. Look at thisexample:

 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Onecan slide down from one point to a connected other one if and only if theheight decreases. One point is connected to another if it's at left, at right,above or below it. In the sample map, a possible slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-...-3-2-1,it would be a much longer run. In fact, it's the longest possible.

Input

Thefirst line contains the number of test cases N. Each test case starts with a line containing the name (it's asingle string), the number of rows Rand the number of columns C. Afterthat follow R lines with C numbers each, defining the heights. R and C won't be bigger than 100, N not bigger than 15 andthe heights are always in the range from 0to 100.

Foreach test case, print a line containing the name of the area, a colon, a spaceand the length of the longest run one can slide down in that area.

Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

 

SampleOutput

Feldberg: 7
Spiral: 25
#include<stdio.h>
#include<string.h>
#define max(x,y) ((x)>(y) ? (x):(y))
int r,c,f[105][105],h[105][105];
char name[25];
const int x[4]={1,-1};
const int y[4]={0,0,1,-1};
int dp(int i, int j)
{
	int a;
	if (f[i][j] > 0) return f[i][j];
	f[i][j]=1;
	for(a=0;a<4;a++)
			if(h[i+x[a]][j+y[a]]!=-1&&h[i][j]>h[i+x[a]][j+y[a]])
				f[i][j] = max(f[i][j], dp(i+x[a], j+y[a])+1);
	return f[i][j];
}
int main()
{
	int t,i,j;
	scanf("%d", &t);
	while (t--)
	{
		memset(f,0,sizeof(f));
		memset(h,-1,sizeof(h));
		scanf("%s%d%d",name, &r, &c);
		for (i=1;i<=r;++i)
			for (j=1;j<=c;++j)
				scanf("%d", &h[i][j]);
		int ans=1;
		for (i=1;i<=r;i++)
			for (j=1;j<=c;j++)
			{
				dp(i, j);
				ans=(f[i][j]>ans)?f[i][j]:ans;
			}       
			printf("%s: %d\n", name, ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值