Where is the Marble?
Where is the Marble? |
Raju and Meena love to play with Marbles. They have got a lotof marbles with numbers written on them. At the beginning, Rajuwould place the marbles one after another in ascending order ofthe numbers written on them. Then Meena would ask Raju tofind the first marble with a certain number. She would count1...2...3. Raju gets one point for correct answer, and Meena getsthe point if Raju fails. After some fixed number of trials thegame ends and the player with maximum points wins. Today it'syour chance to play as Raju. Being the smart kid, you'd be takingthe favor of a computer. But don't underestimate Meena, she hadwritten a program to keep track how much time you're taking togive all the answers. So now you have to write a program, whichwill help you in your role as Raju.
Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consistsbegins with 2 integers:N the number of marbles and Q the number of queries Mina wouldmake. The next N lines would contain the numbers written on the N marbles. These marblenumbers will not come in any particular order. FollowingQ lines will have Q queries. Beassured, none of the input numbers are greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 andQ = 0.
Output
For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend uponwhether or not the query number is written upon any of the marbles. The two different formatsare described below:
- `x found at y', if the first marble with numberx was found at position y.Positions are numbered1, 2,..., N.
- `x not found', if the marble with numberx is not present.
Look at the output for sample input for details.
Sample Input
4 1 2 3 5 1 5 5 2 1 3 3 3 1 2 3 0 0
Sample Output
CASE# 1: 5 found at 4 CASE# 2: 2 not found 3 found at 3
#include<stdio.h>
#include<string.h>
#define max 10005
void quick(int *a,int i,int j)
{
int m,n,temp;
int k;
m=i;
n=j;
k=a[(i+j)/2];
do {
while(a[m]<k&&m<j) m++
while(a[n]>k&&n>i) n--
if(m<=n)
temp=a[m];
a[m]=a[n];
a[n]=temp;
m++;
n--;
}
}while(m<=n);
if(m<j) quick(a,m,j);
if(n>i) quick(a,i,n);
}
int main (void){
int i,j,n,q,marble[max]={0},query[max]={0};
int found=0;
int count=1;
while(scanf("%d%d",&n,&q)==2){
if(n==0&&q==0) break;
for(i=1;i<=n;i++)
scanf("%d",&marble[i]);
for(i=1;i<=q;i++)
scanf("%d",&query[i]);
printf("CASE# %d:\n",count);
count++;
quick(marble,1,n);
for(i=1;i<=q;i++){
found=0;
for(j=1;j<=n;j++){
if(query[i]==marble[j])
{found=1; break;}
}
if(j>=n&&found==0)
printf("%d not found\n",query[i]);
else
printf("%d found at %d\n",query[i],j);
}
j=1;i=1;
}
return 0;
}