CentOS 64 bit bad ELF interpreter

版权声明:欢迎转载,转载请说明出处. 大数据Github项目地址https://github.com/SeanYanxml/bigdata。 https://blog.csdn.net/u010416101/article/details/84730048

前言

前段时间Centos 64系统上发现有这样的错误:

/lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

查了下发现stackoverflow有一样的错误。

CentOS 64 bit bad ELF interpreter
I have just installed CentOS 6 64bit version, I’m trying to install a 32-bit application on a 64-bit machine and got this error:
/lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
I’m new to linux. How do I resolve this?


Solution

  • sudo yum install glibc.i686
  • sudo yum install glibc.i386
  • yum provides /usr/lib/libSM.so.6

我发现/usr/lib/lib下有ld-linux.so.2文件,于是我拷贝一份到了/lib/ld-linux.so.2目录。这大概猜测是rpm包的管理不善,并且系统的文件目录结构不一样导致的。弄过之后,问题fixed


Reference

[1]. CentOS 64 bit bad ELF interpreter
[2]. centos 64位系统如何使用XAMPP?
[3] [d-n-f]( https://note.youdao.com/share/?id = 8530f2fbbd053efbe78d89b569dfb9b6&type=note#/)

没有更多推荐了,返回首页