phpMyAdmin:“您应升级到 MySQL 5.5.0 或更高版本”和“PHP 5.5+ is required”的解决方法

mysql 专栏收录该内容
42 篇文章 0 订阅

随着phpMyAdmin的不断更新,系统对MySQL和PHP的版本要求也在不断的提高。

当你安装phpMyAdmin时也许会遇到“您应升级到 MySQL 5.5.0 或更高版本”、“PHP 5.5+ is required”等,又不能马上升级到规定版本(版本升级并不是一件简单的事),但是此时又急需进行MySQL数据库管理的问题,在这里stutimes提供一个临时解决方案:

一、解决类似“您应升级到 MySQL 5.5.0 或更高版本”问题

问题描述:

phpMyAdmin - 错误
您应升级到 MySQL 5.5.0 或更高版本。

mysql_VERSION

解决方法:

phpMyAdmin目录下libraries\common.inc.php

查找

  1. if (PMA_MYSQL_INT_VERSION < 50500)   

改为

  1. if (PMA_MYSQL_INT_VERSION < 50000)   

 

二、解决类似“PHP 5.5+ is required”问题

问题描述:

PHP 5.5+ is required

PHP 5.3+ is required

PHP 5.2+ is required

。。。。。。

解决方法:

phpMyAdmin目录下libraries\common.inc.php

查找

  1. if (version_compare(PHP_VERSION, '5.5.0', 'lt')) { 
  2.     die('PHP 5.5+ is required'); 
  3. }  

改为

  1. if (version_compare(PHP_VERSION, '5.0.0', 'lt')) { 
  2.     die('PHP 5.0+ is required'); 
  3. }  

这样做虽然能解决部分类似问题,但是还是建议大家升级到相应的版本,以便获得更好的支持。

  • 0
    点赞
  • 5
    评论
  • 0
    收藏
  • 扫一扫,分享海报

评论 5 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:书香水墨 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值