Radar Installation

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47289 Accepted: 10555

Description

Assume the coasting is infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

对于最左端的其雷达的范围为(x1,x2).之后每加入一个,更新区间范围(取两个范围的公共覆盖区间) 若公共区间不存在,则证明此时需要下一个雷达,而此时剩下的雷达又可以从最左端开始了。



#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

struct Node{
    int x;
    int y;
}node[2000];
bool cmp(Node a,Node b){
    return a.x <= b.x;
}

int main(){
    int n = 0,d = 0,t = 0;
    int ans;
    int i;
    double x1,x2;
    double k;
    while(scanf("%d%d",&n,&d)!=EOF,n+d){
        ans = 1;
        t++;
        for(i = 0;i<n;i++){
            scanf("%d%d",&node[i].x,&node[i].y);
            if(abs(node[i].y)> d) ans = -1;
        }
        printf("Case %d: ",t);
        if(ans ==  -1){
            printf("-1\n");
            continue;
        }
        sort(node,node+n,cmp);
        x1 = node[0].x - sqrt(0.0 +d*d-node[0].y *node[0].y);
        x2 = node[0].x + sqrt(0.0 +d*d-node[0].y *node[0].y);
        for(i = 1;i<n;i++){
            k = sqrt(0.0 + d*d-node[i].y*node[i].y);
            if(node[i].x - k <=x2){
                x1 = node[i].x - k;
                x2 = min(k+node[i].x,x2);
            }
            else{
                x1 = node[i].x - sqrt(0.0 + d*d - node[i].y *node[i].y);
                x2 = node[i].x + sqrt(0.0 + d*d - node[i].y *node[i].y);
                ans ++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值