UESTC 893 First Date 计算时间

First Date

Time Limit: 5678/1234MS (Java/Others)     Memory Limit: 65432/65432KB (Java/Others)
 

In 1582, pope Gregory XIII decreed a calendar reform to bring the mean length of the calendar year (counted in days) more in line with the actual number of days in an astronomical year. This calendar reform entailed a transition from the Julian calendar to the Gregorian calendar.

Both the Julian and Gregorian calendars have regular years with 365 days, and so-called leap years with 366 days. In regular years, the month February has 28 days, while in leap years, it has an extra leap day: February 29th.

The single difference between the Julian and Gregorian calendars is in their rule to determine if a year is a leap year. In the Julian calendar, leap years are those years that are divisible by~4. The Gregorian calendar's rule for determining leap years is a bit more complicated: years divisible by 4 are leap years, unless they are divisible by 100 but not by 400.

Following these rules, the years 1600, 1700, 1800, 1900, 2000, 2100, 2200, 2300, and 2400 are all leap years in the Julian calendar. In the Gregorian calendar, the only leap years in this list are 1600, 2000, and 2400.

The old Julian calendar has a mean year length of 365.25 days, while the new Gregorian calendar has a mean year length of 365.2425 days. Given that the actual number of days in an astronomical year is about 365.24219 days, you can see why the Gregorian calendar is an improvement.

As part of the Gregorian reform, a number of dates were skipped, to reverse the effects of having used the Julian calendar for over 1500 years. Specifically, the Gregorian reform decreed that October~4, 1582 (Julian) was to be followed by October~15, 1582 (Gregorian).

However, by the end of the 16th century the Reformation was in full swing. While the Catholic countries tended to follow the Papal decree, many countries continued using the Julian calendar until much later. For example, the United Kingdom switched from the Julian calendar to the Gregorian calendar on September~2, 1752 (Julian) which was followed by September~14, 1752 (Gregorian) --- by that time, 11 dates had to be skipped to make the switch. The last European country to switch was Greece, which made the transition as late as February~15, 1923 (Julian) which was followed by March~1, 1923 (Gregorian), skipping 13 dates.

Given the last day for which the Julian calendar is in effect for some country (expressed as a Julian date), determine the next day's Gregorian date, i.e., the first date that uses the Gregorian calendar.

Input

For each test case, the input consists of one line containing a date in the Julian calendar, formatted as YYYY-MM-DD. This date will be no earlier than October~4, 1582, and no later than October~18, 9999. The given date represents the last day that the Julian calendar is in effect for some country.

Output

For each test case, print the first Gregorian date after the calendar transition.

Sample input and output

Sample Input Sample Output
1582-10-04
1752-09-02
1900-02-25
1923-02-15
1582-10-15
1752-09-14
1900-03-10
1923-03-01
就是判断哪些年里有一天可以跳过,再把这些跳过的天数,加在新的日历上即可。

代码:
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
int dir[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int year,month,day;

int main(){
	while(scanf("%d-%d-%d",&year,&month,&day)!=EOF){
		if(year%400!=0 && year%100==0 && month>2) day++;
		for(int i = 100;i<year;i+=100){
			if(i%400!=0) day++;
		}
		day--;
		if( (year%4==0 && year%100!=0) || (year%400==0) ) dir[2] = 29;
		else dir[2] = 28;
		while(day>dir[month]){
			day-=dir[month];
			month++;
			if(month==13){year++;month=1;}
			if((year%4==0 && year%100!=0) || (year%400==0)) dir[2] = 29;
			else dir[2] = 28;
		}
		printf("%d-%02d-%02d\n",year,month,day);
	}
	return 0;
}

伟大的梦想成就伟大的人,从细节做好,从点点滴滴做好,从认真做好。










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值