杭电HDU OJ A + B Problem II ID1002 AC

A + B Problem II Accepts: 51712 Submissions: 267353
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
Author
Ignatius.L

c程序:

#include <stdio.h>
#include <string.h>
int main() {
    //声明变量 
    int cas,T,i,k,sum[1020],flag;
    char a[1010], b[1010];
    int la,lb,len;
    scanf("%d",&T);
    //最外层循环 
    for(cas = 1; cas <= T; cas++) {
            //读入数据; 
            scanf("%s",a);
            scanf("%s",b);
            //求数据长度 
            la = strlen(a);
            lb = strlen(b);
            len=(la>lb?la:lb);
            //sum第一个值 
            k=0;
            sum[len]=((a[la-1]-'0')+(b[lb-1]-'0')+k)%10;
            if(a[la-1]-'0'+ b[lb-1]-'0' + k>= 10) {
                k=1;
            }
            //sum在a,b都有的位上的值,留一位给最大为进;
            i = 1; 
            while(la-1-i>=0&&lb-1-i>=0){
                sum[len-i] = ((a[la-1-i]-'0')+(b[lb-1-i]-'0') +k)%10;
                if(((a[la-1-i]-'0')+(b[lb-1-i]-'0') +k)>=10) k=1;
                else k=0;
                i++;
            }
            //a比b长时 
            if(la>lb)
                for(i=la-lb-1;i>=0;i--){
                    sum[i+1]=(a[i]-'0'+k)%10;
                    if(a[i]-'0'+k>=10) k=1;
                    else k=0;
                }
            //b比a长时 
            else if(la<lb)
                for(i=lb-la-1;i>=0;i--){
                    sum[i+1]=(b[i]-'0'+k)%10;
                    if(b[i]-'0'+k>=10) k=1;
                    else k=0;
                }
            else{}
            sum[0]=k;//sum最前位的值 
            printf("Case %d:\n",cas);
            printf("%s + %s = ",a,b); 
            //循环输出sum 
            flag = 0;
            for(i=0;i<=len;i++) {
                if(sum[i]==0&&flag==0) continue;
                else {
                    printf("%d",sum[i]);
                    flag =1;
                }
            }
            if(flag == 0) printf("0");
            //换行管理 
            printf("\n");
            if(T>cas) printf("\n");
    }
    return 0;
}

亲测成功

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值