UVA 10382 (13.11.08)

Problem E
Watering Grass
Input:
standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers areinstalled in a horizontal strip of grass l meters long and wmeters wide. Each sprinkler is installed at the horizontal center line of thestrip. For each sprinkler we are given its position as the distance from theleft end of the center line and its radius of operation.

What is the minimum number of sprinklers to turnon in order to water the entire strip of grass?

Input

Input consists of a number ofcases. The first line for each case contains integer numbers n, land w with n <= 10000. The next n lines containtwo integers giving the position of a sprinkler and its radius of operation.(The picture above illustrates the first case from the sample input.)

 

Output

For each test case output the minimum number of sprinklers needed to waterthe entire strip of grass. If it is impossible to water the entire strip output-1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

 

Sample Output

6

2

-1


题意:给出一条长L、宽W的绿化带。下面N行代表N个喷水器,每行两个数字,表示喷水器的位置和喷水范围。要我们求最少需要多少个喷水器,可以使得整个绿化带都喷到

思路及做法:首先要想到要求,是“喷满“绿化带,所以,会用到勾股定理,得到每个喷水器能喷到的最左端和最右端位置。接着使用贪心法,我们按每个喷水器向右喷到的最长距离排序,然后for循环判断,就可以从远到近的搜索,这样每次都可以选到喷的最远的一个喷水器,设置一下停止搜索的条件,跳出后进行判断就好。


AC代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>

using namespace std;

struct D {
    double l;
    double r;
}d[10005];

int cmp(D a, D b) {
    return a.r > b.r;
}

int main() {
    int n;
    double l, w;
    while(scanf("%d %lf %lf", &n ,&l ,&w) != EOF) {
        double p, r;
        for(int i = 0; i < n; i++) {
            scanf("%lf %lf", &p, &r);
            d[i].l = p - sqrt(r * r - w * w / 4);
            d[i].r = p + sqrt(r * r - w * w / 4);
        }
        sort(d, d+n, cmp);
        double count = 0;
        int num = 0;
        int mark = 0;
        while(count < l) {
            int i;
            for(i = 0; i < n; i++) {
                if(d[i].l <= count && d[i].r > count) {
                    count = d[i].r;
                    num++;
                    break;
                }
            }
            if(i == n)
                break;
        }
        if(count >= l)
            printf("%d\n", num);
        else
            printf("-1\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值