UVA 571 (13.11.06)


 Jugs 

In the movie ``Die Hard 3", Bruce Willis and Samuel L. Jackson were confrontedwith the followingpuzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked tofill the 5-gallon jugwith exactly 4 gallons. This problem generalizes that puzzle.


You have two jugs, A and B, and an infinite supply of water. There arethree types of actions thatyou can use: (1) you can fill a jug, (2) you can empty a jug, and (3) youcan pour from one jug tothe other. Pouring from one jug to the other stops when the first jug isempty or the second jug isfull, whichever comes first. For example, if A has 5 gallons and B has 6gallons and a capacity of 8,then pouring from A to B leaves B full and 3 gallons in A.


A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B,respectively, and N is the goal. A solution is a sequence of steps thatleaves exactly N gallons in jug B. The possible steps are

fill A
fill B
empty A
empty B
pour A B
pour B A
success

where ``pour A B" means ``pour the contents of jug A into jug B", and``success" means that the goal has been accomplished.


You may assume that the input you are given does have a solution.

Input 

Input to your program consists of a series of input lines each defining onepuzzle. Input for eachpuzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugsA and B, and N is the goal. You can assume $0 < Ca \le Cb$and $N \le Cb \le 1000$and that A and B are relatively prime to one another.

Output 

Output from your program will consist of a series of instructions from thelist of the potential outputlines which will result in either of the jugs containing exactly N gallons ofwater. The last line ofoutput for each puzzle should be the line ``success". Output lines start incolumn 1 and there should be no empty lines nor any trailing spaces.

Sample Input 

3 5 4
5 7 3

Sample Output 

fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success


题意:给出A、B瓶的容量,给出目标水量数,要求只用fill、pour、empty三种操作。

做法:看过网上的做法,知道了两个瓶子的容量值是互质的,而且不用最优解,这就给出了一个傻瓜式的步骤,有点辗转相除法的意思。

规则:首先加满A,然后倒到B,每从A倒向B一次,就判断一次B中的水量是否达到目标,没达到目标的话,对B判断是否满,满了就倒,对A判断是否不为零,为零就补满。


AC代码:

#include<stdio.h>

int main() {
    int ca, cb, n;
    while(scanf("%d %d %d", &ca, &cb, &n) != EOF) {
        int ta, tb;
        ta = tb = 0;
        while(1) {
            if(ta == 0) {
                ta = ca;
                printf("fill A\n");
            }
            tb = tb + ta;
            printf("pour A B\n");
            if(tb >= cb) {
                ta = tb - cb;
                tb = cb;
                if(tb == n) {
                    printf("success\n");
                    break;
                }
                tb = 0;
                printf("empty B\n");
                if(tb == n) {
                    printf("success\n");
                    break;
                }
            }
            else {
                if(tb == n) {
                    printf("success\n");
                    break;
                }
                ta = 0;
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值