UVA 562 (用硬币拼数额 DP 14.3.11)


  Dividing coins 

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input 

A line with the number of problems n, followed by n times:
  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1


题意:按样例来说,有2组测试点,第一组有3个硬币,面额为2 3 5,第二组有4个硬币,面额为1 2 4 6,针对每一组硬币,分成两堆,两堆的总和差要最小。

思路:首先是要组合出所有可能面额,我第一次用了DP,大致是for(j = 0; j < sum; j++) DP[j + coin[i]] = 1; 结果WA了, 后来摸排了一下, 用第一组样例去推算, 发现会出现这样的情况, DP[2] = 1后, DP[4]也会等于1... 这就导致硬币被重复用了, 看了网上的代码, 要用从后往前推的方式...(我这里将不明白, 大家看代码, DP部分, 可以意会一下)


AC代码:

#include<stdio.h>
#include<string.h>

int main() {
    int coin[105];
    int DP[50005];
    int n;
    scanf("%d", &n);
    while(n--) {
        int m;
        int sum = 0;
        scanf("%d", &m);

        for(int i = 0; i < m; i++) {
            scanf("%d", &coin[i]);
            sum += coin[i];
        }

        memset(DP, 0, sizeof(DP));
        DP[0] = 1;

        for(int i = 0; i < m; i++) {
            for(int j = sum; j >= coin[i]; j--)
                if(DP[j-coin[i]])
                    DP[j] = 1;
        }

        for(int i = sum/2; i >= 0; i--) {
            if(DP[i]) {
                printf("%d\n", sum - 2*i);
                break;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值