SCAU专题训练II - DP---C-- Dividing coins

题目描述

It’s commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over
a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce,
they stretched the coin to great length and thus created copper-wire.
Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with
coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch
of the past couldn’t stand the fact that a division should favour one of them and they always wanted
a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but
being capable of making an equal division as fair as possible is something that will remain important
forever…
That’s what this whole problem is about. Not everyone is capable of seeing instantly what’s the
most fair division of a bag of coins between two persons. Your help is asked to solve this problem.
Given a bag with a maximum of 100 coins, determine the most fair division between two persons.
This means that the difference between the amount each person obtains should be minimised. The
value of a coin varies from 1 cent to 500 cents. It’s not allowed to split a single coin.
Input
A line with the number of problems n, followed by n times:
• a line with a non negative integer m (m ≤ 100) indicating the number of coins in the bag
• a line with m numbers separated by one space, each number indicates the value of a coin.
Output
The output consists of n lines. Each line contains the minimal positive difference between the amount
the two persons obtain when they divide the coins from the corresponding bag.
Sample Input
2
3
2 3 5
4
1 2 4 6
Sample Output
0
1

看到这题应该很明显了,就是一个01背包的平衡问题。对于这道题目,我们可以知道既然两个人分的钱要尽量相同,所以其中一个人的钱肯定是大于等于sum(总钱)的一半。那么这题只需要假设背包的最大容量是sum/2就好了,然后求在此背包容量下,取得的最大价值。然后答案就是sum-2*dp[sum/2];
这题有个比较坑的地方,因为case的范围没有给,所以我wa了一次,把int换成longlong就可以过了。。这个地方我是真的无语。。想象一下假如有一天,case的范围没给,但是他要用到高精度,结果wa一直错,是不是会怀疑人生。。。
代码如下:

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<map>
#include<vector>
#include<queue>
using namespace std;
#define ll long long
int main()
{
    ll CASE;
    cin>>CASE;
    while(CASE--)
    {
        int n,sum=0,total;
        cin>>n;
        int v[102];
        int dp[50005]={0};
        for(int i=0; i<n; i++)
        {
            cin>>v[i];
            sum=sum+v[i];
        }
        total=sum/2;
        for(int i=0;i<n;i++)
        {
            for(int j=total;j>=v[i];j--)
                dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
        }
        cout<<sum-2*dp[total]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_春与修罗

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值