UVA 350 (13.07.26)

 Pseudo-Random Numbers 

Computers normally cannot generate really random numbers, but frequentlyare used to generate sequences of pseudo-random numbers. These are generatedby some algorithm, butappear for all practical purposes to be really random. Random numbersare used in many applications, including simulation.

A common pseudo-random number generation technique is called the linearcongruential method. If the last pseudo-random number generated was L,then the next number is generatedby evaluating ( tex2html_wrap_inline32 , where Z is a constantmultiplier, I is a constant increment, and M is a constant modulus.For example, suppose Z is 7, I is 5, and M is 12. If the firstrandom number (usually called the seed) is 4, then we can determine thenext few pseudo-random numbers are follows:

tabular21

As you can see, the sequence of pseudo-random numbers generated by thistechnique repeats after six numbers. It should be clear that the longestsequence that can be generated usingthis technique is limited by the modulus, M.

In this problem you will be given sets of values for Z, I, M, and theseed, L. Each of these will have no more than four digits. For each suchset of values you are to determine the lengthof the cycle of pseudo-random numbers that will be generated. But becareful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for Z, I, M,and L. The last line will contain four zeroes, and marks the end of theinput data. L will be less than M.

Output

For each input line, display the case number (they are sequentially numbered,starting with 1) and the length of the sequence of pseudo-random numbersbefore the sequence is repeated.

Sample Input

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

Sample Output

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220

题意:利用立体所给的方法生成伪随机数, 并求这个伪随机数的不重复数字的最长长度 我的教训: 开始看题目, 以为生成的数都是要和第一个数比较, 所以RE了, 很奇怪为什么是RE, 而不是WA 后来发现可能因为后来生成的随机数不会与第一个随机数一样, 一直死循环了 看了份别人的题解, 发现是每次生成的数都是要和前面所有的数比的 这样就A了, 挺简单的~ AC代码: 
#include<stdio.h>

int main() {
	int Z, I, M, L[1000000];
	int sum;
	int cas = 0;
	int count;
	int flag;
	while(scanf("%d%d%d%d", &Z, &I, &M, &L[0])) {
		if(Z == 0 && I == 0 && M == 0 && L[0] == 0)
			break;
		int i;
		count = 0;
		flag = 1;
		while(flag) {
			count++;
			L[count] = (Z * L[count-1] + I) % M;
			for(i = 0 ; i < count; i++) {
				if(L[count] == L[i]) {
					flag = 0;
					break;
				}
			}
		}
		printf("Case %d: %d\n", ++cas, count - i);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值