Pseudo-Random Numbers

题目:

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.
A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( Z x L + I ) mod M, where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows:

这里写图片描述

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.
In this problem you will be given sets of values for Z, I, M, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

Input
Each input line will contain four integer values, in order, for Z, I, M, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.

Output
For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

Sample Input
7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

Sample Output
Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220


题意:

重复输入4个数z, i, m, l,计算规则是l = (z * l + i) %m,然后题目告诉我们必定会出现重复的数,我们要做的是找出循环长度。

思路:

期初我的思路是定义一个temp = (z * temp + i)%m和一个计数器cnt,当出现temp为l的时候cnt的计数就是答案,但是却发现有一组数据的数有提前出现循环的情况而且出现循环的数不是l,这就有问题了。因此找另一个办法,定义一个数组vis访问数组,temp计算的值为下标,每出现一次就将vis[temp]赋值1,并且定义一个数组num第几个出现的数组,每出现一个数num[temp] = cnt++,这样当遇到vis[temp] == 1的时候就知道循环出现的这个数在上一次出现是第几个,用现在的cnt - num[temp]就是答案啦。


代码如下:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int num[100000];
int vis[100000];

int main()
{
    long long z, i, m, l, cnt, time = 0;
    while(cin >> z >> i >> m >> l && (z + i + m + l) > 0)
    {
        memset(vis, 0, sizeof(vis));
        memset(num, 0, sizeof(num));
        printf("Case %d: ", ++time);
        long long temp;
        temp = (z * l + i) % m;
        cnt = 1;
        while(1)
        {
            if(vis[temp] == 1)
                break;
            num[temp] = cnt++;
            vis[temp] = 1;
            temp = (z * temp + i) % m;
        }
        cout << cnt - num[temp] << endl;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值