UVA 156 (13.08.04)

 Ananagrams 

Most crossword puzzle fans are used to anagrams--groupsof words with the same letters in different orders--for exampleOPTS, SPOT, STOP, POTS and POST. Some words however do not have thisattribute, no matter how you rearrange their letters, you cannot formanother word. Such words are called ananagrams, an example isQUIZ.

Obviously such definitions depend on the domain within which we areworking; you might think that ATHENE is an ananagram, whereas anychemist would quickly produce ETHANE. One possible domain would be theentire English language, but this could lead to some problems. Onecould restrict the domain to, say, Music, in which case SCALE becomesa relative ananagram (LACES is not in the same domain) but NOTEis not since it can produce TONE.

Write a program that will read in the dictionary of a restricteddomain and determine the relative ananagrams. Note that single letterwords are, ipso facto, relative ananagrams since they cannot be``rearranged'' at all. The dictionary will contain no morethan 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80characters long, but may contain any number of words. Words consist ofup to 20 upper and/or lower case letters, and will not be brokenacross lines. Spaces may appear freely around words, and at least onespace separates multiple words on the same line. Note that words thatcontain the same letters but of differing case are considered to beanagrams of each other, thus tIeD and EdiT are anagrams. The file willbe terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of asingle word that is a relative ananagram in the input dictionary.Words must be output in lexicographic (case-sensitive) order. Therewill always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample output

Disk
NotE
derail
drIed
eye
ladder
soon


题意: 在一堆单词里, 找出那些没有字母调换顺序的单词

如acme, 在这堆词里还出现了came, 后者是因前者字母调换顺序得到, 故不用输出

而Disk就没有, 所以输出


另外注意: 不区分大小写;


做法:

首先, 我们可以想到, 只要两个单词可以通过调换字母顺序得到对方, 那么组成他们的字母是一样的, 这是第一步思路;

接着, 输出是要把单词按字典序输出, 故一开始输入完成后先qsort一下, 再用word数组, 把处理成小写后的单词储存下来;

然后, 我们把每个单词中的字母排成最小字典序;

最后,通过word字符数组进行搜索, 已排成字典序的单词若只出现一次, 就输出一开始未转化成小写的原始单词~


AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

char str[125][25];
char word[125][25];

int cmp_str(const void *_a, const void *_b) {
	char *a = (char*)_a;
	char *b = (char*)_b;
	return strcmp(a,b);
}

int cmp_char(const void *_a, const void *_b) {
	char *a = (char*)_a;
	char *b = (char*)_b;
	return *a - *b;
}

int main() {
	char tmp[25];
	int num = 0;
	//输入:
	while(scanf("%s", tmp), tmp[0] != '#')
		strcpy(str[num++], tmp);
	//将字符串按字典序排:
	qsort(str, num, sizeof(str[0]), cmp_str);
	//全部处理成小写, 且其中的字符排成字典序, 放到word数组:
	for(int i = 0; i < num; i++) {
		int len = strlen(str[i]);
		for(int j = 0; j < len; j++) {
			if(str[i][j] >= 'A' && str[i][j] <= 'Z')
				word[i][j] = str[i][j] + ('a' - 'A');
			else
				word[i][j] = str[i][j];
		}
		word[i][len] = '\0';
		qsort(word[i], len, sizeof(char), cmp_char);
	}
	//判断是否出现, 不出现
	for(int i = 0; i < num; i++) {
		int count = 0;
		for(int j = 0; j < num; j++) {
			if(!strcmp(word[i], word[j]))
				count++;
		}
		if(count == 1)
			puts(str[i]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值