UVA_156: Ananagrams

Description

Most crossword puzzle fans are used to anagrams--groupsof words with the same letters in different orders--for exampleOPTS, SPOT, STOP, POTS and POST. Some words however do not have thisattribute, no matter how you rearrange their letters, you cannot formanother word. Such words are called ananagrams, an example isQUIZ.Obviously such definitions depend on the domain within which we areworking; you might think that ATHENE is an ananagram, whereas anychemist would quickly produce ETHANE. One possible domain would be theentire English language, but this could lead to some problems. Onecould restrict the domain to, say, Music, in which case SCALE becomesa relative ananagram (LACES is not in the same domain) but NOTEis not since it can produce TONE.Write a program that will read in the dictionary of a restricteddomain and determine the relative ananagrams. Note that single letterwords are, ipso facto, relative ananagrams since they cannot be``rearranged'' at all. The dictionary will contain no morethan 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80characters long, but may contain any number of words. Words consist ofup to 20 upper and/or lower case letters, and will not be brokenacross lines. Spaces may appear freely around words, and at least onespace separates multiple words on the same line. Note that words thatcontain the same letters but of differing case are considered to beanagrams of each other, thus tIeD and EdiT are anagrams. The file willbe terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of asingle word that is a relative ananagram in the input dictionary.Words must be output in lexicographic (case-sensitive) order. Therewill always be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat
 ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#

Sample Output

Disk
NotE
derail
drIed
eye
ladder
soon


分析:本题很适合用STL的map,接收所有的字符串存放在vector中,对每个字符串标准化(转小写排序)存放在map中,最后遍历vector,找到那些map中只有一个的string。 注意标准化是按题意来的,因为字符串中的每个字符可以任意顺序并且不考虑大小写,所以直接转话为小写并排序则得到的是同一个串。


#include <iostream>
#include <algorithm>
#include <map>
#include <string>
#include <vector>

using namespace std;

map<string,int> cnt;
vector<string> words;

string repr(string s)
{
	string ans = s;
	for(int i=0; i<s.length(); i++)
		ans[i] = tolower(s[i]);
	sort(ans.begin(),ans.end());
	return ans;
}

int main()
{
	string s;
	while(cin >> s)
	{
		if(s[0]=='#')break;
		words.push_back(s);
		string ss = repr(s);
		if(!cnt.count(ss)) cnt[ss]=0;
		cnt[ss]++;
	}

	vector<string> ans;
    for(int i=0; i<words.size(); i++)
		if(cnt[repr(words[i])]==1) ans.push_back(words[i]);
    sort(ans.begin(),ans.end());
    for(int i=0; i<ans.size(); i++)
		cout << ans[i] << endl;
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值