HDU 2199 (13.08.07)

Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input

    
    
2 100 -4
 

Sample Output

  
  
1.6152 No solution!

此题用二分法求解~

AC代码:

#include<stdio.h>

double f(double x) {
    return (8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6);
}

double myabs(double x) {
    if(x < 0)
        return x * (-1);
    else
        return x;
}

int main() {
    int T;
    scanf("%d", &T);
    while(T--) {
        double begin = 0.0;
        double end = 100.0;
        double mid;
        double Y;
        scanf("%lf", &Y);
        if(f(0.0) > Y || f(100.0) < Y) {
            printf("No solution!\n");
            continue;
        }
        mid = (begin + end) / 2;
        while(myabs(f(mid) - Y) > 1e-5) {
            if(f(mid) > Y) {
                end = mid;
                mid = (begin + end) / 2;
            }
            else if(f(mid) < Y){
                begin = mid;
                mid = (begin + end) / 2;
            }
        }
        printf("%.4lf\n", mid);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值