Can you solve this equation?(二分)

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

 

 

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 

 

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 

 

Sample Input

 

2 100 -4

 

 

Sample Output

 

1.6152 No solution!

 

0-100之间是递增的,可以用二分

#include<cstdio>
#include<cmath>
#define eqs 1e-12
double hany(double y)
{	
	return 8.0*pow(y,4.0)+7.0*pow(y,3)+2.0*pow(y,2.0)+3*pow(y,1.0)+6.0;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		double y;
		scanf("%lf",&y);
		if(y<hany(0)||y>hany(100))
		  printf("No solution!\n");
		else
		{
			double l=0.0,r=100.0,mid;
			int size=50;
			while(size--)
			{
				mid=(l+r)/2.0;
				if(hany(mid)>y)
				  r=mid+eqs;
				else l=mid+eqs;
			}
			printf("%.4lf\n",l);
		}		
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值