POJ 1010 STAMPS

题目链接 : POJ1010 
STAMPS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14086 Accepted: 3927

Description

Have you done any Philately lately? 

You have been hired by the Ruritanian Postal Service (RPS) to design their new postage software.  The software allocates stamps to customers based on customer needs and the denominations that are currently in stock.

Ruritania is filled with people who correspond with stamp collectors. As a service to these people, the RPS asks that all stamp allocations have the maximum number of different types of stamps in it.  In fact, the RPS has been known to issue several stamps of the same denomination in order to please customers (these count as different types, even though they are the same denomination).  The maximum number of different types of stamps issued at any time is twenty-five.

To save money, the RPS would like to issue as few duplicate stamps as possible (given the constraint that they want to issue as many different types).  Further, the RPS won't sell more than four stamps at a time.

Input

The input for your program will be pairs of positive integer sequences, consisting of two lines, alternating until end-of-file.  The first sequence are the available values of stamps, while the second sequence is a series of customer requests.  For example:

1 2 3 0 ; three different stamp types
7 4 0 ; two customers
1 1 0 ; a new set of stamps (two of the same type)
6 2 3 0 ; three customers

Note: the comments in this example are *not* part of the data file; data files contain only integers.

Output

For each customer, you should print the "best" combination that is exactly equal to the customer's needs, with a maximum of four stamps. If no such combination exists, print "none". 
The "best" combination is defined as the maximum number of different stamp types.  In case of a tie, the combination with the fewest total stamps is best.  If still tied, the set with the highest single-value stamp is best.  If there is still a tie, print "tie". 

For the sample input file, the output should be:

7 (3): 1 1 2 3 
4 (2): 1 3 
6 ---- none
2 (2): 1 1
3 (2): tie
That is, you should print the customer request, the number of types sold and the actual stamps.  In case of no legal allocation, the line should look like it does in the example, with four hyphens after a space.  In the case of a tie, still print the number of types but do not print the allocation (again, as in the example).Don't print extra blank at the end of each line.

Sample Input

1 2 3 0	; three different stamp types
7 4 0		; two customers
1 1 0		; a new set of stamps (two of the same type)
6 2 3 0	; three customers

Sample Output

7 (3): 1 1 2 3 
4 (2): 1 3 
6 ---- none
2 (2): 1 1
3 (2): tie

Source

搜索题  很久以前写的了  忘了题意了 以后有空补~

 

#include<stdio.h>
#include<string.h>
#include<ctype.h>
#include<stdlib.h>

int stam[100],ans[20],peo,val,flag;
int cmp(void const *a,void const *b)
{
	int *c=(int*)a;
	int *d=(int*)b;
	return (*c>*d)?1:-1;
}
int weit(int *va)
{
	int num=4;
	for(int i=0;i<4;i++)
		if(va[i]==-1) num--;
	int temp=4-num;
	for(int i=4-num;i<3;i++)
		if(va[i]==va[i+1]) num--;
	return num*10000+temp*100;
}
int choose(int num)
{
	int va[5];
	for(va[0]=-1;va[0]<num;va[0]++)
		for(va[1]=va[0];va[1]<num;va[1]++)
			for(va[2]=va[1];va[2]<num;va[2]++)
				for(va[3]=va[2];va[3]<num;va[3]++)
				{
					int sum=0;
					for(int i=0;i<4;i++)
						if(va[i]==-1) continue;
						else sum+=stam[va[i]];
					if(peo==sum)
					{
						int now=weit(va)+stam[va[3]];
						if(now>val)
						{
							flag=0;
							val=now;
							for(int i=0;i<4;i++) ans[i]=va[i];
						}
						else if(now==val)
						{
							flag=1;
						}
					}
	
				}
	return 0;
}
int main()
{
	while(scanf("%d",stam)==1)
	{
		int i=1;
		while(scanf("%d",stam+i))
		{
			if(!stam[i++]) break;
		}
		qsort(stam,i-1,sizeof(stam[0]),cmp);
		while(scanf("%d",&peo))
		{
			if(!peo) break;
			val=0;flag=0;
			choose(i-1);
			if(flag) printf("%d (%d): tie\n",peo,val/10000);
			else 
			{
				if(val) 
				{
					printf("%d (%d):",peo,val/10000);
					for(int i=0;i<4;i++)
						if(ans[i]==-1) continue;
						else printf(" %d",stam[ans[i]]);
					putchar(10);
				}
				else printf("%d ---- none\n",peo);
			}
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值