FZOJ 1752 A^B mod C

题目链接 :

Problem 1752 A^B mod C

Accept: 563    Submit: 2535
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input

3 2 42 10 1000

Sample Output

124

Source

FZU 2009 Summer Training IV--Number Theory

 

这题直接快速幂里面的算乘法会超longlong

所以要用快速乘法来代替乘法  a*b相当于是算(a+a+a....+a)

类似于算 a^b=a*a*a....*a  一样的思路 

这题让我深刻体会到了 % 也就是取模运算有多慢。。有兴趣可以自己去体会一下

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
using namespace std;


unsigned long long pow_mult(unsigned long long a,unsigned long long b,unsigned long long mod)
{
    unsigned long long c=0;
    while(b)
    {
        if(b&1) c+=a;
        if(c>=mod) c-=mod;
        a<<=1;
        if(a>=mod) a-=mod;
        b>>=1;
    }
    return c;
}
unsigned long long pow_mod(unsigned long long a,unsigned long long b,unsigned long long mod)
{
    a%=mod;
    unsigned long long c=1;
    while(b)
    {
        if(b&1) c=pow_mult(c,a,mod);
        b>>=1;
        a=pow_mult(a,a,mod);
    }
    return c;
}
int main()
{
 //   freopen("1.txt","r",stdin);
    unsigned long long a,b,c;
    while(scanf("%I64d%I64d%I64d",&a,&b,&c)==3)
        printf("%I64d\n",pow_mod(a,b,c));
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值