ZOJ 2290 Game

题目链接 : ZOJ2290

Game

 


 

Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

 


 

Two players(A and B) take turns to take stones form a heap of N stones.

There are some rules:
1.A always takes first. He can take arbitrary number of stones but not all of them.
2.The number of the one who will take should less than or equal the twice of the other one taken last time. But must more than one or one.
3.The one who take take the last one stone is the winner.
4.The two players are clever enough, they can make the best choice.

Input

Every test case has only one line with one integer N(2 <= N <= 100000000), the numbers of the stones.

Output

If A will lose output "lose"

If A can win,output the numbers A should take at the first time. If there are more ways to make A win, output the smallest one.

Sample Input

4

Sample Output

1

 

 

 


                            Author: YANG, Xuan
                                        Source: ZOJ Monthly, January 2005

 


博弈题

首先必败点是斐波那契数 

因为设x y (x<y)为先手必败局 也就是说后手能取到x 和 y局面的最后一颗棋子

对于x+y 只要满足 2x>=y(也就是说不能让先手一下就取走x个,剩下y个)

那么后手一定能把棋子取成y个 而y是先手必败局 所以x+y (满足2x>=y)也是个先手必败局

1和2容易验证为先手必败 然后斐波那契数正好也满足 2a(n-1)>=an

所以得证

这里也可以说一下 如果题目是1倍的话 先手必败是 2^n n为正整数

证明可以和上面一样 

通过上面的1,2倍 大致可以看出比败局有个规律 设倍数为k 

k=1    an=2*a(n-1)    也就是an=a(n-1)+a(n-1)

k=2    an=an+a(n-1) 

但是这里说明 k>2没有 an=an+a(n-k+1) 的必败局规律  

具体计算要严格按照上面的证明来算

 

然后要求输出必胜的话 第一步最少要区多少个

就通过递归的思想来就行了

有a个棋子 我们想取a的最后一个

而最近的一个先手必败为b

那么第一步取走a-b个一定能赢  但这个不一定是最少的

现在 我们的目的是要取到a-b个中的最后一个  

显然的递归出现了..接下来实现看代码吧

 

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
using namespace std;



int fib[50];
int main()
{
 //   freopen("1.txt","r",stdin);
    fib[0]=fib[1]=1;
    for(int i=2;i<40;i++)
        fib[i]=fib[i-1]+fib[i-2];
    int n;
    while(scanf("%d",&n)==1)
    {
        bool flag=1;
        for(int i=0;i<40;i++)
            if(fib[i]==n) flag=0;
        if(flag)
        {
            int ans;
            for(int i=39;i>0;i--)
            {
                if(fib[i]==n)
                {
                    ans=fib[i];
                    break;
                }
                n%=fib[i];
            }
            printf("%d\n",ans);
        }
        else printf("lose\n");
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断路器保护灵敏度校验整改及剩余电流监测试点应用站用交流系统断

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值