UVa10815 Andy's First Dictionary

ProblemB: Andy's First Dictionary

Timelimit: 3 seconds


Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

Joke and image taken from the Web

这题其实就从一大堆字符串中剥离出单词出来,并按照字典序排好即可,最后去重输出。不过这题有个陷阱就是里面所说的单词种类不超过5,000,实际上由于会有单词的重复,所以实际数组大小要开到50,000才A过了。

#include <iostream>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 300;
const int MAX = 50000;

char s_1[N];
char s_2[N];
char dic[MAX][N];

int cmp(const void *a,const void *b) {
	return strcmp((char*)a,(char*)b);
}

int main() {
	int tmp = 0;
	memset(dic,0,sizeof(dic));
	while (cin >> s_1) {
		int t = 0;
		int len = strlen(s_1);
		for (int i = 0; i < len; i++) {
			if (islower(s_1[i])) {
				s_2[t] = s_1[i];
				t++;
			}
			else if (isupper(s_1[i])) {
				s_2[t] = tolower(s_1[i]);
				t++;
			}
			else if (s_2[0]) {
				strcpy(dic[tmp],s_2);
				tmp++;
				t = 0;
				memset(s_2,0,sizeof(s_2));
			}
		}
		if (s_2[0]) {
			strcpy(dic[tmp],s_2);
			tmp++;
		}
		memset(s_1,0,sizeof(s_1));
		memset(s_2,0,sizeof(s_2));
	}
	qsort(dic,tmp,sizeof(char)*N,cmp);
	for (int i = 0; i < tmp; i++) {
		if (i > 0 && strcmp(dic[i],dic[i-1])==0)
			continue;
		cout << dic[i] << endl;	
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值