UVa414 Machined Surfaces


 Machined Surfaces 

An imaging device furnishes digital images of two machined surfaces thateventually will be assembled incontact with each other. The roughness of this final contact is to be estimated.

A digital image is composed of the two characters, "X" and " "(space). There are always 25 columns to animage, but the number of rows, N, is variable. Column one (1) will alwayshave an "X" in it and will bepart of the left surface. The left surface can extend to the right fromcolumn one (1) as contiguous X's.

Similarly, column 25 will always have an "X" in it and will be partof the right surface. The right surfacecan extend to the left from column 25 as contiguous X's.

Digital-Image View of Surfaces

 
		 Left     		                           Right

XXXX XXXXX tex2html_wrap_inline50

XXX XXXXXXX

XXXXX XXXX

XX XXXXXX

. .

. .

. .

XXXX XXXX

XXX XXXXXX tex2html_wrap_inline52

tex2html_wrap_inline54 tex2html_wrap_inline56

1 25

In each row of the image, there can be zero or more space charactersseparating the left surface from the right surface.There will never be more than a single blank region in any row.

For each image given, you are to determine the total ``void" that willexist after the left surface has beenbrought into contact with the right surface. The ``void" is the totalcount of the spaces that remains betweenthe left and right surfaces after theyhave been brought into contact.

The two surfaces are brought into contact by displacing them strictlyhorizontally towards each other until arightmost "X" of the left surface of some row is immediately to theleft of the leftmost "X" of the right surface of that row.There is no rotation or twisting of these two surfaces as they are broughtinto contact; they remain rigid, and only move horizontally.

Note: The original image may show the two surfaces already in contact,in which case no displacement enters into the contact roughness estimation.

Input

The input consists of a series of digital images. Each image data set hasthe following format:

First line -
A single unsigned integer, N, with value greater thanzero (0) and less than 13. Thefirst digit of N will be the first character on a line.
Next N lines -
Each line has exactly 25 characters; one or more X's, then zero or more spaces, then one or more X's.

The end of data is signaled by a null data set having a zero on the firstline of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the totalvoid (count of spaces remainingafter the surfaces are brought into contact). Use the default output fora single integer on a line.

Sample Input(character "B" for ease of reading.The actual input file will use the ASCII-space character, not "B").

4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0

Sample Output

4
0
0

这题大意就是将图上由X构成的左右两堵墙合并后,中间会剩下多少空隙。先是求出中间空隙最小的一行的空隙长度,然后查找比它空隙大的各行,将多余的空隙累加,最后输出。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int N = 100;
const int INF = 1 << 29;

int main() {
	int Case;
	char str[N];
	int num[N];
	while (cin >> Case) {
		if (!Case)
			break;
		memset(num,0,sizeof(num));
		int min = INF;
		int ans = 0;
		getchar();
		for (int i = 0; i < Case; i++) {
			gets(str);
			for (int j = 0; j < N && str[j]; j++) {
				if (str[j] == ' ')
					num[i]++;
			}
			if (min > num[i])
				min = num[i];
		}
		for (int i = 0; i < Case; i++) {
			if (num[i] > min)
				ans += num[i] - min;
		}
		cout << ans << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值